glassfish
  1. glassfish
  2. GLASSFISH-15893

Error while adding password for Domain in Domain/New Administrator Password page.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1_dev
    • Fix Version/s: 3.1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS: Windows 2008 Server
      Browser firefox 3.6, IE8.

      Description

      Build used : GF v3.1 promoted b41. ( latest-ogs-windows.exe)

      In the Admin Console Domain/Administrator Password tab, try to add a new password and click Save. Below Error is displayed:
      An error has occurred
      'CreateNew' is required for handler 'saveUser'!

      In the Server.log there are no Exceptions, but the below message is displayed:

      [#|2011-02-08T12:13:05.992-0800|INFO|oracle-glassfish3.1|org.glassfish.admingui|
      _ThreadID=17;_ThreadName=Thread-1;|Exception Occurred :'CreateNew' is required f
      or handler 'saveUser'!|#]

      Attached screenshot.

        Issue Links

          Activity

          Anissa Lam added a comment -

          -How bad is its impact? (Severity)
          medium high. user will not be able to use this screen to change admin password. Although there is workaround, this is in your face issue and commonly used function.

          -How often does it happen? (Frequency)
          Whenever user goes to domain page -> Admin Password page to change password. Given that we ship with no password as default, there may be many user using this feature.

          -How much effort is required to fix it? (Cost)
          1 hour.

          -What is the risk of fixing it? (Risk)
          extremely small. It only affects this one page.

          -Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
          Yes, user can select server-config -> Security -> Realm ->admin-realm and Manage User from there.

          If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
          Yes. I believe this is in the release note already, since we have to tell user who upgrade from v2 that this option is not supported. (someone better confirm thats this is in the release note)

          -How long has the bug existed in the product?
          Introduced recently.

          -Do regression tests exist for this issue?
          We probably didn't have dev test for this page. Otherwise we will catch that. I will add devtest for this.

          -Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          The usual test they run and the GUI dev test.
          I have also tested this again by 'adding new user in other realm' , 'edit user i other realm' since this is calling the same java handler.

          -When will a tested fix be ready for integration?
          Ready now, svn diff attached.

          ~/Awork/V3/v3 1046) svn diff admingui/common
          Index: admingui/common/src/main/resources/appServer/serverInstAdminPassword.jsf
          ===================================================================
          — admingui/common/src/main/resources/appServer/serverInstAdminPassword.jsf (revision 44919)
          +++ admingui/common/src/main/resources/appServer/serverInstAdminPassword.jsf (working copy)
          @@ -69,7 +69,7 @@
          onClick=" if ( checkPSW() ){ return submitAndDisable(this, '$resource

          {i18n.button.Processing}

          '); } return false; " >
          <!command
          prepareSuccessfulMsg();

          • saveUser( Realm="# {pageSession.authRealm}" configName="#{pageSession.configName}" UserId="#{sessionScope.userName}" GroupList="#{pageSession.group}" Password="#{pageSession.password}" );
            + saveUser( Realm="#{pageSession.authRealm}

            " configName="#

            {pageSession.configName}

            " UserId="#

            {sessionScope.userName}

            " GroupList="#

            {pageSession.group}

            " Password="#

            {pageSession.password}

            " CreateNew="false");
            />
            </sun:button>
            </sun:panelGroup>

          Jason Lee added a comment -

          Change looks good to me.

          Chris Kasso added a comment -

          Approved for RC3.

          Anissa Lam added a comment -

          Fix checked into trunk & 3.1 branch.
          trunk: rev# 44997
          3.1 branch: rev# 44998
          ========================

          Log Message:
          ------------
          GLASSFISH-15893. Add the required param for saveUser() in the Admin Password page.
          fix is in trunk as well.
          Reviewed by Jason
          Approved by Chris.

          Revisions:
          ----------
          44998

          Modified Paths:
          ---------------
          branches/3.1/admingui/common/src/main/resources/appServer/serverInstAdminPassword.jsf

          shaline added a comment -

          Verified in Nightly GF build dated b42-02-09-2011.


            People

            • Assignee:
              Anissa Lam
              Reporter:
              shaline
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: