Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1_b41
    • Fix Version/s: None
    • Component/s: cdi, classloader
    • Labels:
      None

      Description

      When deploying the attached WAR you will notice an "UnsupportedOperationException", but I already filed another GF bug for that (GLASSFISH-15905).

      the application uses CDI (and MyFaces' CoDI CDI-Extensions). The application does contain a few classes, that are annotated as "@Named" beans and I am using them as my "JSF managed beans", e.g:

      @Named("createPerson")
      @RequestScoped
      public class CreatePersonController
      {
      ....
      }

      The beans.xml file is located in WEB-INF/classes/META-INF/ (as beans.xml)

      => This should be fine, since that would be exactly the same location for a "JAR" file (the META-INF)

      However, I am getting "PropertyNotFoundException"

        Issue Links

          Activity

          mwessendorf added a comment -

          Hello Siva,

          is it possible to try this with GF 3.1 and Weld 1.2 ?

          Thanks!

          Sivakumar Thyagarajan added a comment -

          Thanks for the new war. This appears to be the visibility scenario where Beans/Interceptor from a bundled library in a WAR(WEB-INF/lib/myfaces-extcdi-dist-jsf20-0.9.3-SNAPSHOT) are not available to Beans in the WAR BeanDeploymentArchive.

          GlassFish passes the following WAR to Weld for processing, and because of https://issues.jboss.org/browse/WELD-846, cyclic dependencies between a bundled library and WAR, the interceptor is not applied to Beans in the WAR.

          [|ID: GlassfishIssues_new, bdaType= WAR, accessibleBDAs #:19, [WEB-INF/lib/myfaces-extcdi-dist-jsf20-0.9.3-SNAPSHOT,WEB-INF/lib/myfaces-extcdi-dist-jsf20-0.9.3-SNAPSHOT-sources,,,,,,,,,,,,,,,,,,], Bean Classes #: 8,[net.wessendorf.enterprise.faces.CreatePersonController, net.wessendorf.enterprise.faces.AllPersonsController, net.wessendorf.enterprise.jpa.dao.PersonDao, net.wessendorf.enterprise.beans.Person, net.wessendorf.enterprise.beans.Friend, net.wessendorf.enterprise.beans.PersistentObject, net.wessendorf.enterprise.service.PersonService, net.wessendorf.enterprise.service.PersonServerImpl], ejbs=[]

          ---->ID: WEB-INF/lib/myfaces-extcdi-dist-jsf20-0.9.3-SNAPSHOT, bdaType= UNKNOWN, accessibleBDAs #:2, [WEB-INF/lib/myfaces-extcdi-dist-jsf20-0.9.3-SNAPSHOT-sources,GlassfishIssues_new,], Bean Classes #: 374,[...], ejbs=[]

          Please use the workaround discussed in http://java.net/jira/browse/GLASSFISH-15721?focusedCommentId=301147&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_301147

          Sivakumar Thyagarajan added a comment - - edited

          Issue's root cause is GLASSFISH-15721

          Sivakumar Thyagarajan added a comment -

          FYI.

          I ensured that this scenario works against a local GlassFish 3.1 integration of trunk build of Weld/core merged with the changes in https://github.com/stuartwdouglas/core/tree/WELD-846. The application deployed with no changes and I was able to use the app

          $ asadmin deploy /space/downloads/GlassfishIssues_new.war
          Application deployed with name GlassfishIssues_new.
          Command deploy executed successfully.
          — server log snippet –

          [#|2011-02-11T19:36:42.225+0530|INFO|glassfish3.2|javax.enterprise.resource.webcontainer.jsf.config|_ThreadID=22;_ThreadName=Thread-1;|Initializing Mojarra 2.1.0 (FCS 2.1.0-b11) for context '/GlassfishIssues_new'|#]

          [#|2011-02-11T19:36:42.493+0530|INFO|glassfish3.2|com.ocpsoft.pretty.PrettyFilter|_ThreadID=22;_ThreadName=Thread-1;|PrettyFilter starting up...|#]

          [#|2011-02-11T19:36:42.745+0530|INFO|glassfish3.2|com.ocpsoft.pretty.PrettyFilter|_ThreadID=22;_ThreadName=Thread-1;|PrettyFilter initialized.|#]

          [#|2011-02-11T19:36:42.753+0530|INFO|glassfish3.2|javax.enterprise.system.container.web.com.sun.enterprise.web|_ThreadID=88;_ThreadName=Thread-1;|WEB0671: Loading application [GlassfishIssues_new] at [/GlassfishIssues_new]|#]

          [#|2011-02-11T19:36:42.785+0530|INFO|glassfish3.2|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=88;_ThreadName=Thread-1;|GlassfishIssues_new was successfully deployed in 3,386 milliseconds.|#]

          — server log snippet —

          Sivakumar Thyagarajan added a comment -

          This is a duplicate of the core issue described in GLASSFISH-15721.

          The official workaround for the 3.1 release is described at http://java.net/jira/browse/GLASSFISH-15721?focusedCommentId=301147&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_301147


            People

            • Assignee:
              Sivakumar Thyagarajan
              Reporter:
              mwessendorf
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: