glassfish
  1. glassfish
  2. GLASSFISH-15908

[BLOCKING] After Updating from 3.0 to B41 using UC, many exceptions in the server.log while loading the Admin Console

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1_b41
    • Fix Version/s: 3.1_b42
    • Component/s: packaging
    • Labels:
      None
    • Environment:

      Description

      While testing the new Update process on my Win7 system (asqe-win7-3.us.oracle.com)with v3.0 installed (build 74b) and no Admin password set, several exceptions are seen in the server log (see attachment) while loading the Admin Console. After a while the Login Admin console page is displayed, but not the Admin Console "Common Tasks" page.

      The same configuration was tested on build 38 without the above described problem.

      The same procedure works on v3.0.1 installation(glassfish-3.0.1-b22-windows) on the same system. The system is updated properly and the Admin console loads correctly. The sample application is viewable and useable. Have not tried anything further (like instance or cluster creation as of yet).

      To reproduce the failure, perform the following steps:
      1. Install GF 3.0 build 74b
      2. Start the domain
      3. Check the server is up and running
      4. Make sure Admin Console is accessible
      5. Deploy sample app (hello.war)
      6. Shut down the domain server
      7. Start "Updatetool" (<GF_Directory>/glassfishv3/updatetool/bin/updatetool)
      8. Edit the preferred repository to the dev.glassfish.org repository
      9. Select "Available Updates" (left side of the screen - Application Images)
      10. Update all the pkgs.
      11. Check versions of the updates and make sure it matches the latest build
      12. Monitor the server log (tail -f server.log)
      13. Start the domain with --upgrade. (asadmin start-domain --upgrade --domaindir <GF_Dir>/glassfish/domains domain1)
      14. Start the domain (asadmin start-domain)
      15. Make sure it's up and running (check localhost:8080)
      16. Go to the Admin Console (URL localhost:4848)

      In the server log you will see several exceptions (see the attached server log) and the Admin Console login page is displayed (nor the "Common Tasks" page).

      1. server.log_2011-02-09T07-03-13
        1.91 MB
        Alex Pineda
      1. update-error.jpg
        474 kB

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        Tentative fix would consist of following:

        • adding 'incorporate' dependency on glassfish-scripting@3.1 package to glassfish-web-incorporation package
        • modify 'require' dependency on jersey package in glassfish-web-profile metapackage to specify dependency on jersey@1.5
        Snjezana Sevo-Zenzerovic added a comment -

        How bad is its impact? (Severity)
        Direct update from v3 FCS installation to 3.1 FCS produces corrupted installation image. This qualifies as both potential support call generator and an in-your-face usability issue.

        How often does it happen? (Frequency)
        For all updates where the starting point is v3 FCS installation.

        How much effort is required to fix it? (Cost)
        Minimal effort for workspace fix (requires only adjustment of package dependencies for two packager modules). Moderate effort to test the fix since it requires setting up a private copy of stable repository and publishing updated packages to it.

        What is the risk of fixing it? (Risk)
        Minimal risk. 3.0.1 update path will be tested for regressions.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        Workaround is to run 'pkg fix glassfish-common' command on affected installation but it is far from obvious for the end user.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        Yes.

        How long has the bug existed in the product?
        Jersey package content which indirectly causes the issue has been in place for more than two months. Updated glassfish-scripting package became available in the dev repository in the last week. It is unclear at which point repository content triggered faulty image update behavior.

        Do regression tests exist for this issue?
        No automated regression test. Manual v3 and 3.0.1 update test plan will be used to check for regressions.

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        v3 and 3.0.1 updates to 3.1.

        When will a tested fix be ready for integration?
        By 02/10 COB (tentatively).

        Chris Kasso added a comment -

        Approved for RC3.

        Snjezana Sevo-Zenzerovic added a comment -

        Fix checked in as revision 45044 (3.1 branch) and 45046 (trunk).

        Before the integration I run full update test scenarios using v3 FCS and 3.0.1 FCS installations as starting point. Repository used for that testing was replica of current stable.glassfish.org repository plus set of 3.1 IPS packages built from current workspace. Instead of switching preferred repository to dev.glassfish.org as in original QA test scenario, the URL of stable.glassfish.org publisher was being set to private test repo URL. This should very closely resemble the update scenario for an actual 3.1 FCS end user.

        Alex Pineda added a comment -

        Verified the fix in build 42. Tested it on the same configuration that I found the issue and everything is working now.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Alex Pineda
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: