Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1_b38
    • Fix Version/s: None
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Windows

      Description

      Hi there,
      The dynamic-reload setting is set in true(Domain->Applications Configuration->Reload). I deployed WAR with servlet to server. Then I changed servlet, compiled it and copied *.class to application folder to server but behavior of application didn't change. Is dynamic reloading supported for servlets?
      Thank you

        Issue Links

          Activity

          Hong Zhang added a comment -

          This is expected behavior. We only support the reloading of the entire application, and not the individual web components in the application. There is a similar RFE filed for this, I will close this one as the duplicate of the other one:
          http://java.net/jira/browse/GLASSFISH-12793

          tetyanac added a comment -

          Could you please explain how dynamic reload is working?
          I try to unpack WAR containing servlet to C:\glassfish3.1\glassfish\domains\domain1\applications\testapp but behavior of application didnt change.How should I update the application?

          Hong Zhang added a comment -

          Please see the document here:
          http://download.oracle.com/docs/cd/E19798-01/821-1750/fwakh/index.html

          Basically after your initial deployment of the war file, the application bits will reside in domains/domain1/applications/<application name>. You can then make any additional change in that directory. When you change the timestamp of the special .reload file in this directory (or create it if it's not there yet), the modified application bits will be reloaded.

          tetyanac added a comment -

          I deployed application dynamicreload.war and checked settings :
          ...\dynamicreload>asadmin get *.dynamic-reload-enabled
          configs.config.default-config.admin-service.das-config.dynamic-reload-enabled=true
          configs.config.server-config.admin-service.das-config.dynamic-reload-enabled=true
          Command get executed successfully.

          Then I changed TestServlet.java, compiled it and packaged to WAR then I unpacked the content of WAR to domains/domain1/applications/dynamicreload and created .reload, opened it, changed content and saved (this changed the timestamp of file). Then I checked the result in browser but the behaviour of application is same as it was before. It changed only after I executed the reloading of application. Why it doesnt work?

          I dont see how to add attachment(probably because the issue is closed), but I can provide it if you need.

          Thanks

          Hong Zhang added a comment -

          You can attach the application (and the modified bits) in its duplicated issue (12793) with exact steps and we will take look to see if we can reproduce it.
          So after you saved the .reload file, you didn't see anything in the server.log indicating the application is being reloaded?
          What do you mean it changed only after you executed reloading of the application, do the "reload" here mean redeploy the application?

          tetyanac added a comment -

          I will continue under duplicated issue (12793).


            People

            • Assignee:
              Hong Zhang
              Reporter:
              tetyanac
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: