Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b42
    • Component/s: docs
    • Labels:
      None

      Description

      Raising an umbrella issue for the man pages of various commands for Bugswat review. Please refer the "depends on" issues list.

        Issue Links

          Activity

          Paul Davies added a comment -

          This bug is the umbrella bug for all man page fixes for the RC 3 build. I have increased the priority to ensure that it is approved for integration in RC 3.

          Paul Davies added a comment -

          How bad is its impact? (Severity)
          The fix needs to occur now because the issue:

          • Is likely to generate a customer support call
          • Significantly impacts the operation of a primary release driver feature
          • Is an in-your-face issue that will touch the majority of users

          How often does it happen? (Frequency)
          Every time a user requests help on an affected subcommand.

          How much effort is required to fix it? (Cost)
          Approx 4 writer days (3 writers working 1 day each on the fixes, + 1 day for integration and testing)

          What is the risk of fixing it? (Risk)
          Low.

          Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
          Yes - deliver the fixes only in the version that is published on the web.The workaround could be employed by an end user but only if the user is aware of the workaround.

          If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
          Yes.

          How long has the bug existed in the product?
          The errors were introduced in this release.

          Do regression tests exist for this issue?
          N/A

          Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          QuickLook would be sufficient for this purpose.

          When will a tested fix be ready for integration?
          Before the RC 3 build is started.

          Chris Kasso added a comment -

          Approved for RC3.

          Chris Kasso added a comment -

          These changes will not be localized for 3.1 thus users in non-EN locales will continue to see the incorrect man pages. The release notes should direct these users to the unbundled versions of the man pages for the corrections.

          Paul Davies added a comment -

          For the 3.1 branch, change is committed in revision 45101.

          Paul Davies added a comment -

          For the trunk, the fix is committed in revision 45163.

          Scott Fordin added a comment -

          Added topic to 3.1 Release Notes. Added "3_1-release-note-added" tag.


            People

            • Assignee:
              Paul Davies
              Reporter:
              Jagadish
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: