glassfish
  1. glassfish
  2. GLASSFISH-15935

Weld in Glassfish does not find @Named beans, when the beans.xml is stored in WEB-INF/classes/META-INF

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1_b41
    • Fix Version/s: None
    • Component/s: cdi
    • Labels:
      None

      Description

      Trying to isolate the "two" issues from java.net/jira/browse/GLASSFISH-15906

      I have a SIMPLE war file, that has a few classes (annotated with @Named and other CDI annotations)

      These classes are in WEB-INF/classes;

      However, the Weld in Glassfish does not find those "@Named beans".
      The is stored in WEB-INF/classes/META-INF ...

        Issue Links

          Activity

          Sivakumar Thyagarajan added a comment -

          Marking as duplicate of GLASSFISH-15018

          Sivakumar Thyagarajan added a comment -

          WEB-INF/classes/META-INF in the war is not a portable location to place beans.xml. As discussed in http://java.net/jira/browse/GLASSFISH-15009?focusedCommentId=147541&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_147541
          the CDI specification indicates that the beans.xml must be place in WEB-INF directory of the WAR. So, please modify the war to place the beans.xml under WEB-INF

          However to address this common deployment scenario, we already have an active RFE ( GLASSFISH-15018 ) in GlassFish to support this mode of packaging. Please note that even if GlassFish supports this scneario after we fix GLASSFISH-15018, this would still be non-portable packaging and may not work in other application servers.

          Closing this as a duplicate of GLASSFISH-15018


            People

            • Assignee:
              Sivakumar Thyagarajan
              Reporter:
              mwessendorf
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: