glassfish
  1. glassfish
  2. GLASSFISH-15946

EclipseLink regression: ManyToOne target, which extends a MappedSuperclass, fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 3.1_b41
    • Fix Version/s: None
    • Component/s: entity-persistence
    • Labels:
      None

      Description

      I am posting this bug here to track the EclipseLink bug I filed: https://bugs.eclipse.org/bugs/show_bug.cgi?id=336879

      This is present in EclipseLink 2.2.0-SNAPSHOT, which is the version used by Glassfish by default. I want to make sure that Glassfish 3.1 final incorporates a fix here. We have hundreds of these mappings deployed today and they work just fine in older versions of EclipseLink.

        Activity

        Chris Kasso added a comment -

        This appears to be more of an edge case. Two workarounds exist. See:

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=336879

        for details.

        Chris Kasso added a comment -

        I'm closing this as won't fix since we will not fix this for 3.1. The underlying issue is represented by:

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=336879

        and will be picked up in a future release of GlassFish.


          People

          • Assignee:
            tware
            Reporter:
            ljnelson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: