glassfish
  1. glassfish
  2. GLASSFISH-16096

WARNINGs during deployment: Invalid zip file: WEB-INF/lib/Bundle252.jar

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.1_b43
    • Fix Version/s: 4.0_b82_EE7MS7
    • Component/s: OSGi-JavaEE
    • Labels:
      None

      Description

      asadmin deploy --type=osgi style deployment of a WAB containing a Bundle-ClassPath entry of "." can lead to warnings during deployment:

      [#|2011-02-25T00:19:42.247+0530|WARNING|glassfish3.2|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=47;_ThreadName=pool-6-thread-1;|DPL8004: file open failure; file = file:/tmp/osgiapp1169388501707691598/WEB-INF/lib/Bundle252.jar|#]

      [#|2011-02-25T00:19:42.248+0530|WARNING|glassfish3.2|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=47;_ThreadName=pool-6-thread-1;|error in opening zip file -- invalid zip file: file:/tmp/osgiapp1169388501707691598/WEB-INF/lib/Bundle252.jar|#]

      [#|2011-02-25T00:19:42.312+0530|WARNING|glassfish3.2|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=47;_ThreadName=pool-6-thread-1;|error in opening zip file: file path: /tmp/osgiapp1169388501707691598/WEB-INF/lib/Bundle252.jar|#]

      [#|2011-02-25T00:19:42.324+0530|WARNING|glassfish3.2|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=47;_ThreadName=pool-6-thread-1;|DPL8004: file open failure; file = file:/tmp/osgiapp1169388501707691598/WEB-INF/lib/Bundle252.jar|#]

      Please note, this does not happen if we use fileinstall to deploy the WAB. So, I suspect it has something to do with our assumption about bundle jar and reference: scheme used by asadmin deploy --type=osgi path. Test case is attached here with. This issue was originally reported in GLASSFISH-15497.

        Issue Links

          Activity

          TangYong added a comment -

          The issue should be fixed because of GLASSFISH-19662.

          I have also confirmed that after fixing GLASSFISH-19662 including GLASSFISH-19688, the issue did not happen(not any warning in server.log).

          So, I think the issue should be closed.

          Sanjeeb Sahoo added a comment -

          The root cause for GLASSFISH-19662 and this bug is same. When we see a Bundle-ClassPath of "." for a WAB, we are supposed to create a jar file in <exploded area>/WEB-INF/lib/Bundle<Id>.jar. Such a jar file should be everything the original bundle has. When we deploy such WAB using asadmin deploy --type interface, the WAB first gets exploded in domain/applications/ area by deployment backend. In OSGi javaee container, we try to avoid exploding the WAB again, but we had failed to take care of the fact that uri is a directory. We were trying to create a jar file out of a directory and it resulted in an ascii file. This causes the ZipException as reported here.

          Sanjeeb Sahoo added a comment -

          Closing duplicate of GLASSFISH-19662. I have verified that the attached test case works with no exception after applying fix for that issue.


            People

            • Assignee:
              Sanjeeb Sahoo
              Reporter:
              Sanjeeb Sahoo
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: