glassfish
  1. glassfish
  2. GLASSFISH-16125

Launch link brings 404 error after installing an Add-On and before restart

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b43
    • Fix Version/s: 3.1.1
    • Component/s: admin_gui
    • Labels:
      None

      Description

      While verifying another bug, http://java.net/jira/browse/GLASSFISH-14310, I encountered an issue where launch link was bringing a 404 page. Steps to reproduce:

      1. In Admin Console go to update tool and click on Available Add-Ons.
      2. Choose an add-on and click Install.
      3. Without restarting server go to an already deployed application and click on Launch link - 404 error is displayed instead of expected application's links. The url displayed in the browser is:

      http://tuppy.us.oracle.com:4848/updateCenter/applications/webApplicationLinks.jsf?appID=hello&contextRoot=/hello

      instead of the regular url when things work that's:

      http://tuppy.us.oracle.com:4848/common/applications/webApplicationLinks.jsf?appID=hello&contextRoot=/hello

      Restarting server clears this problem.

      1. server.log
        173 kB
        lidiam
      1. launch-404error.JPG
        58 kB

        Activity

        sirajg added a comment -

        I cannot reproduce this problem. Did you use the back button?

        sirajg added a comment -

        Cannot reproduce using the instructions given in the bug report. Please reopen if the issue can still be reproduced.

        lidiam added a comment -

        Reopening to add verified tag.

        lidiam added a comment -

        Verified in build b08.

        Anissa Lam added a comment -

        reopen to mark the fix version field.

        Anissa Lam added a comment -

        change Resolution back to Fixed.


          People

          • Assignee:
            sirajg
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: