glassfish
  1. glassfish
  2. GLASSFISH-16138

Stuck thread after server stop prevents JVM stop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: embedded
    • Labels:
      None
    • Environment:

      Windows 2003 Server
      jdk 1.6.0_18

      Description

      Non-daemon com.sun.corba.ee.impl.javax.rmi.CORBA.Util.KeepAlive thread prevents JVM from exiting.
      This thread is launched when an application with an EJB is deployed on an embedded server. After the undeployment and server stop the thread continues to run.

        Activity

        marina vatkina added a comment -

        GF Embedded API are used to run the test

        Bhavanishankar added a comment -

          People

          • Assignee:
            Bhavanishankar
            Reporter:
            alex_ryzh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: