glassfish
  1. glassfish
  2. GLASSFISH-16163

JSF 2.x should not run in 1.x modus when web.xml is declared as Servlet 2.5

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: jsf
    • Labels:
      None

      Description

      Source: http://stackoverflow.com/questions/5208390

      Glassfish appears to put JSF 2.x in 1.x modus when web.xml is declared as Servlet 2.5. This makes no sense since JSF 2.x is designed to be backwards compatible with Servlet 2.5.

      The 1.x modus should only kick in when the `web.xml` is declared as Servlet 2.4.

        Activity

        rogerk added a comment -

        Unless I'm missing something here, I cannot reproduce your issue.
        We have many JSF 2.0 demo applications with web.xml version declarations of 2.5, and they run and deploy fine - in both JSF 2.0.X and 2.1.X.


          People

          • Assignee:
            rogerk
            Reporter:
            balusc
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: