glassfish
  1. glassfish
  2. GLASSFISH-16184

Admin GUI fails to display - server error instead

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.1_b09
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Windows 7 64 bit, JDK 1.6.0_22 32 bit, GF 3.1 FCS bld 43

      Description

      This appears to be similar to http://java.net/jira/browse/GLASSFISH-12937

      It appears to happen if/when a logged in administration console times out and then you try to use the UI, eg. click on the Home button after the timeout.

      I've attached the stack trace that occurs in the server.log when this happens.

      Once this happens the admin GUI is no longer accessible until you restart the server which is a real problem for production environments.

      1. 16184-console.diff
        15 kB
        Jason Lee
      2. 16184-rest.diff
        20 kB
        Jason Lee
      3. AdminGuiException.txt
        5 kB
        nbw

        Issue Links

          Activity

          Jason Lee added a comment -

          My steps to reproduce have quit working for some reason. Back to square one.

          Jason Lee added a comment -

          OK. I think I've found it. Again. It seems that, for some reason, the HTTP Session is still active, but the REST session token the console uses has expired (or was deleted, etc). When this happens, the Console itself still works, but all attempts to talk to the backend fail due to authentication failures. I have a test in place that demonstrates the issue, and am currently working through a fix. Commit should happen shortly.

          Jason Lee added a comment -
          • Why fix this issue in 3.1.1?

          This user-reported bug affects the stability/usability of the console.

          • Which is the targeted build of 3.1.1 for this fix?

          b07

          • Do regression tests exist for this issue?

          The diff attached adds a console test

          • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

          Console and REST tests

          scatari added a comment -

          Approved for 3.1.1. Please make sure to include "Fix in version" as "3.1.1_b09". Currently B09 is targeted for 06/23.

          Jason Lee added a comment -

          This fix for this issue and a regression test have been committed to the trunk and branch (r47520).


            People

            • Assignee:
              Jason Lee
              Reporter:
              nbw
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: