glassfish
  1. glassfish
  2. GLASSFISH-16215

debug message missing when debugging server startup

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.1, 4.0_b01
    • Component/s: admin
    • Labels:
      None

      Description

      Am trying to attach debugger during GF startup, so I have suspend=y in domain.xml. When starting with "asadmin start-domain --debug," there used to be a message sent to console telling me that the server was waiting for someone to attach on the debugging port. This message is now missing. Instead, I only see:

      — begin —
      hostname% ./asadmin start-domain --debug
      Waiting for domain1 to start ......
      — end —

      The message eventually appears, but it's not until startup has completed (after I've finished my debug session):

      — begin —
      hostname% ./asadmin start-domain --debug
      Waiting for domain1 to start ................................................................
      Successfully started the domain : domain1
      domain Location: /Users/bobby/work/ws/v3/distributions/glassfish/target/glassfish3/glassfish/domains/domain1
      Log File: /Users/bobby/work/ws/v3/distributions/glassfish/target/glassfish3/glassfish/domains/domain1/logs/server.log
      Admin Port: 4848
      Debugging is enabled. The debugging port is: 9009
      Command start-domain executed successfully.
      — end —

      Without this message, it could confuse anyone trying to debug as it appears now that the server just isn't responsive.

        Activity

        Hide
        Byron Nevins added a comment -

        This started happening after the "early logging" changes.

        Show
        Byron Nevins added a comment - This started happening after the "early logging" changes.
        Hide
        Byron Nevins added a comment -

        It's even worse. It only emits a message when you give "--debug" arg.
        If debug-enabled is set in domain.xml then nothing is reported!

        Show
        Byron Nevins added a comment - It's even worse. It only emits a message when you give "--debug" arg. If debug-enabled is set in domain.xml then nothing is reported!
        Hide
        Byron Nevins added a comment -

        2 changes:

        (1) if debugging is enabled in domain.xml and/or the --debug option was used then a message is emitted

        (2) Now we check for suspended. If it is set then an early message is emitted:

        D:\gf\v3\admin\cli>call asadmin start-domain
        Debugging is enabled and the server is suspended. Please attach to the debugging port at: 9009
        Successfully started the domain : domain1
        domain Location: D:\glassfish3\glassfish\domains\domain1
        Log File: D:\glassfish3\glassfish\domains\domain1\logs\server.log
        Admin Port: 4848
        Debugging is enabled. The debugging port is: 9009

        Show
        Byron Nevins added a comment - 2 changes: (1) if debugging is enabled in domain.xml and/or the --debug option was used then a message is emitted (2) Now we check for suspended. If it is set then an early message is emitted: D:\gf\v3\admin\cli>call asadmin start-domain Debugging is enabled and the server is suspended. Please attach to the debugging port at: 9009 Successfully started the domain : domain1 domain Location: D:\glassfish3\glassfish\domains\domain1 Log File: D:\glassfish3\glassfish\domains\domain1\logs\server.log Admin Port: 4848 Debugging is enabled. The debugging port is: 9009
        Hide
        Byron Nevins added a comment -

        D:\gf\v3\admin>svn commit
        Sending admin\cli\src\main\java\com\sun\enterprise\admin\cli\LocalStrings.properties
        Sending admin\cli\src\main\java\com\sun\enterprise\admin\cli\StartServerHelper.java
        Sending admin\launcher\src\main\java\com\sun\enterprise\admin\launcher\GFLauncher.java
        Transmitting file data ...
        Committed revision 45573.

        Done. Thanks for finding this, Bobby...

        Show
        Byron Nevins added a comment - D:\gf\v3\admin>svn commit Sending admin\cli\src\main\java\com\sun\enterprise\admin\cli\LocalStrings.properties Sending admin\cli\src\main\java\com\sun\enterprise\admin\cli\StartServerHelper.java Sending admin\launcher\src\main\java\com\sun\enterprise\admin\launcher\GFLauncher.java Transmitting file data ... Committed revision 45573. Done. Thanks for finding this, Bobby...
        Hide
        Bobby Bissett added a comment -

        Looks good. Thanks for the quick fix!

        Show
        Bobby Bissett added a comment - Looks good. Thanks for the quick fix!
        Hide
        Byron Nevins added a comment -

        it won't let me edit so I'm reopening. Weird.

        Show
        Byron Nevins added a comment - it won't let me edit so I'm reopening. Weird.
        Hide
        Byron Nevins added a comment -

        .

        Show
        Byron Nevins added a comment - .

          People

          • Assignee:
            Byron Nevins
            Reporter:
            Bobby Bissett
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: