glassfish
  1. glassfish
  2. GLASSFISH-16216

annotation scanning was not done for library jars in directory format

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.1_b01
    • Component/s: deployment
    • Labels:
      None

      Description

      This is a related glassfish side issue for this Eclipse plug in issue:

      http://java.net/jira/browse/GLASSFISHPLUGINS-324

      This is to address the deployment problem when an EJB jar is inside the WEB-INF/lib directory and in exploded format.

      The cause has been identified and a fix will be checked in soon.

      There are parts in the glassfish annotation processing code that assumes the library jars are always in file format and we need to update them to include the directory format as well to support the Eclipse plug in.

        Activity

        Hong Zhang added a comment -

        Checked in the fix. Have verified the changes (with simulated directory structure) for the test case (Fred) attached in the plug in issue. Ludo will verify the changes with the Eclipse plugin.


          People

          • Assignee:
            Hong Zhang
            Reporter:
            Hong Zhang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: