glassfish
  1. glassfish
  2. GLASSFISH-16249

EAR deployment with multiple embedded WARs broken in 3.1

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: 4.0_b74
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      RedHat Linux, Windows, Ubuntu Linux

      Description

      We are trying to upgrade to 3.1. Our application is packaged and deployed as an EAR file with multiple EJB and WARs embedded. Some of the WAR files have web services for deployment, and some do not. The 3.1 deployment mechanism is fundamentally broken in this case. It appears that the web service deployment piece ends up scanning all the wars in the EAR for metadata (annotations), and then trying to deploy the collected web services in every WAR in the EAR, not just the one that had the annotated web service classes.

      This appears to be the same symptoms as the following bug, but for web services instead.

      http://java.net/jira/browse/JAVASERVERFACES-1995

      I have attached a very simple test EAR file. Trying to deploy this will demonstrate the error. You will see error messages about duplicate web service deployments and class not found exceptions.

        Activity

        Hong Zhang added a comment -

        Bhakti: I thought we handled similar situation in the webservices code before and we could tell which context is the right context that we should process. Can you take a further look at this?

        Lukas Jungmann added a comment -

        In latest trunk, I can see only warning about missing TestApp-ejbClient.jar. Other than that, app deploys fine, si this must be already fixed. Feel free to reopen if it happens again.

        ymajoros added a comment -

        I still have this in another setup (but still EAR+multiple WARs), in GF 3.1.2

        Lukas Jungmann added a comment -

        Can you check it in GF 4, please? Thanks

        nabizamani added a comment -

        The issue still exists in Glassfish 4.0 but only without that "WEB9052" prefix. Since this issue here is closed I have created a new issue here: https://java.net/jira/browse/GLASSFISH-20720
        On the other side, I can also reproduce the issue in Glassfish 3.1.2.2.


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            noetro
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: