glassfish
  1. glassfish
  2. GLASSFISH-16308

Admin console not loading on Safari after enabling secure-admin

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Server: FreeBSD 8.2 x64
      Client: Mac OS X 10.6.7

      Description

      • Download and install Glassfish 3.1 final (b43)
      • asadmin start-domain
      • asadmin enable-secure-admin
      • asadmin stop-domain
      • asadmin start-domain
      • open Safari web-browser and try to connect to the admin console via https on port 4848

      Result: the admin console GUI won't load: error 404: "Failed to open page"

      The result is the same whether you use Glassfish's own self-signed certificate or if you use an authority signed certificate.

      On Firefox everything works perfectly. It connects to the admin console GUI just fine.

      No error or exception can be found in server.log.

        Activity

        ref added a comment - - edited

        On mobile Safari on iOS it also works perfectly fine.

        With Glassfish 3.0.1 I never had problems connecting to the admin GUI. That's the reason I consider this issue a Glassfish problem.

        Connecting on port 8181 over https works also fine when using Safari. It's only the admin GUI that doesn't work.

        It may as well be a Safari bug...

        ref added a comment -

        On another Mac it asks for a certificate when trying to access the admin GUI when using Safari.

        Anissa Lam added a comment -

        "On another Mac it asks for a certificate when trying to access the admin GUI when using Safari."
        Are you saying on this Mac, it is working fine ?
        I am using Safari 5.0.3 and MacOS 10.5.8, I cannot reproduce the problem.
        As this is related to cert., transferring to security for initial evaluation.

        ref added a comment - - edited

        On one Mac it doesn't work at all, on the other one it asks for a client certificate:
        "This website requires a client certificate".

        When I ignore this message, I can sometimes* access the admin GUI.

        I'm currently trying to figure out the problem.

        • Depends on settings

        edit: tested it on two more machines: same problem. Can't access the admin GUI.

        kumarjayanti added a comment -

        Assign to tim for initial eval.

        Tim Quinn added a comment -

        I'm not sure what I can add, Kumar.

        ref, I have a similar set-up to Anissa's: Leopard (10.5.8), Safari 5.0.4 (5533.20.27). (It is normal for the browser to prompt you about a self-signed certificate.)

        The scenario works for me just fine.

        Please let us know exactly what version of Mac OS X and Safari work and which do not since you see different results on different systems.

        Is there a chance that a user on any of the systems viewed the certificate when challenged and clicked on the "always trust" box? (I see the initial cert prompt and when I accept it it takes a moment but the admin console appears fairly quickly.) This should not affect the behavior but we should not rule anything out at this point.

        ref added a comment - - edited

        Thanks Tim.

        All three machines are running Mac OS X 10.6.7 and Safari 5.0.4 (5533.20.27).

        On the Mac that prompts me for a certificate, it prompts me to select a client certificate (I don't use a self-signed certificate but even when using a self-signed one it behaves the same):

        "The website xxxxx requires a client certificate.
        --------------------------------------
        The website requires a certificate to validate your identity. Select the certificate to use when you connect to this website and then click Continue") and there's not even a checkbox. "

        [edited]
        On the machines where it doesn't work, it takes a long time (about a minute) before I get to see the 404.
        [/edited]

        I tried on yet another Mac running 10.6.5 and Safari 5.0.2 and it works perfectly fine there. Doesn't even prompt me about a certificate. So I reckon it might be a Safari problem.

        Anissa Lam added a comment -

        If you use another browser eg firefox on that same machine that you cannot access the console, does it work for you ?

        Is it possible for you to "Reset Safari" by going to Preferences -> Reset Safari and reset everything , quit and restart safari again to see if that change anything ?

        ref added a comment - - edited

        Anissa, when using Firefox on the same machine, it works perfectly fine.

        Resetting Safari didn't work. No changes after resetting.

        So it looks more like a Safari problem than a GlassFish problem...

        Anissa Lam added a comment -

        >> So it looks more like a Safari problem than a GlassFish problem...

        But all 3 machines are running the same OS and Safari (Mac OS X 10.6.7 and Safari 5.0.4 (5533.20.27).
        and only 1 machine failed.
        There must be some system configuration differences in that one machine that causes the problem.

        ref added a comment -

        No, it fails on 2 machines.

        Tim Quinn added a comment -

        I am closing this issue as not reproducible - by us.

        If you find a difference in the system config or Safari config between where this works and where it fails then we can see if there is something wrong on the GlassFish end. If you can get to that point please re-open this issue with the added information.

        christopherrued added a comment -

        I observed very similar behavior running on Windows Server, Glassfish 3.1.1 b05. In my case, enable-secure-admin caused "connection timeout" with any browser I used. The admin console worked perfectly beforehand. I'm not sure where to look next, but I'm willing to troubleshoot with you.

        ref added a comment -

        Good that someone can reproduce the problem. I have exactly the same problem when enabling enable-secure-admin.

        I don't know if we can do something to fix the problem, though.

        I think that GlassFish 3.1 handles certificates differently or that some changes have been made from 3.0.1 to 3.1 which breaks the admin console when enabling secure-admin.

        It would be great if someone could look into the issue. I'm willing to help.

        Would be great if the ticket could be re-opened. Or do I have to clone it?

        psartini added a comment -

        I've the same problem. Cloned this issue: GLASSFISH-17132

        nabizamani added a comment - - edited

        I can reproduce this issue with Safari 5.1.2 on OS X Lion + Glassfish 3.1.1.
        I also have no problems with Firefox and no Problem with Chrom! Only Safari makes problems!
        But I am also sure that before my Safari Update everything worked just fine - so in other words: this seems to be a Safari issue!!!
        Anyway, we need a solution for that. Maybe you could investigate...

        Please reopen this issue!

        ps
        see here for example: https://discussions.apple.com/thread/3192257?start=0&tstart=0

        buddypine added a comment -

        Same issue here with Safari 5.1.7 and Glassfish 3.1.2

        norasodan added a comment -

        I can reproduce with Safari 5.1.7 on OSX Lion and Glassfish 3.1.2 b23.

        Please reopen this issue!

        rherschke added a comment -

        also the problem here:
        Glassfish 3.1.2 b23
        Safari 5.1.7 (7534.57.2)
        OS X Lion 10.7.4

        worked with Safari pre 5.0 versions.

        Please reopen this issue and please don't assume to start a browser nor an OS-war on this issue!

        Tim Quinn added a comment -

        I have just retried this with the same setup which rherschke described. Naturally, it works fine for me.

        I was able to get something close - but not exactly the same - as the failure people are describing here by doing the following:

        1. I was connected to Oracle's internal network using VPN; Safari was open and I had visited various sites.
        2. I installed GlassFish 3.1.2 b23.
        3. asadmin start-domain
        4. asadmin change-admin-password (this is required or GlassFish rejects the next step).
        5. asadmin enable-secure-admin
        6. asadmin stop-domain
        7. asadmin start-domain
        8. Use Safari to connect to https://localhost:4848. Worked.
        9. Use Safari to connect to https://192.168.2.102:4848. Worked.
        10. Use Safari to connect to https://host-assigned-by-vpn:4848. Worked.

        11. Disconnect from VPN. I did not restart GlassFish or Safari.
        12. Use Safari to connect to https://192.168.2.102:4848. Worked.
        13. Run uname -n to get the current host name.
        14. Use Safari to connect to https://output-from-uname-minus-n:4848. It took a VERY long time but it eventually worked.
        15. Restart Safari.
        16. Repeat 14. Worked immediately.

        I have auto-proxy discovery set in networking.

        I believe it is well-known (if not well-loved) behavior of Safari that going on or off VPN causes delays like what I described in step 14, and I have seen this trying to connect to other web sites. Restarting Safari clears that up.

        I can believe that, depending on exactly what goes on inside Safari and the network stack during step 14, I might have received a timeout instead of a slow response if it took a little longer.

        Those of you who have seen this problem: Could there be something related to networking on your Macs that might be contributing to this? Going on or off VPN, or moving from one network to another?

        Please report what sort of name you are specifying for the host. We don't need to know the exact name; it just might help to know whether you are using numerical addresses, whether they are 192.168.x.y or "real" numeric addresses, "localhost," some other host name. Also please check your /etc/hosts file.


          People

          • Assignee:
            Tim Quinn
            Reporter:
            ref
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 hours
              2h
              Remaining:
              Remaining Estimate - 2 hours
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified