glassfish
  1. glassfish
  2. GLASSFISH-16363

automatic self recovery failure with xa tx on 2 DBs

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.1_b03
    • Component/s: jts
    • Labels:
      None
    • Environment:

      RHL5 and JDK1.6.0_24

      Description

      automatic self recovery failure with xa tx on 2 DBS
      glassfish-3.1-b43.zip

      I observed this intermittent failure of automatic self recovery
      a few times in full core run, tx module run and cliweb2 suite run.
      I will provide test details next for
      tx-cliweb2-t4-killGFInstanceAutomaticSelfRecovery

        Activity

        marina vatkina added a comment -

        Fixed with rev 46217. The actual fix for this issue is this change in JavaEETransactionManagerJTSDelegate:

        • TransactionServiceProperties.getJTSProperties(habitat, false);
          + Properties props = TransactionServiceProperties.getJTSProperties(habitat, false);
          + DefaultTransactionService.setServerName(props);
        marina vatkina added a comment -
        • Why fix this issue in 3.1.1?

        Automatic transaction recovery on server restart is not working

        • Which is the targeted build of 3.1.1 for this fix?

        The next.

        • Do regression tests exist for this issue?

        Yes. A devtest was added. SQE test existed since 3.1

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Transaction tests, including recovery tests

        scatari added a comment -

        Approved. Please look here http://wikis.sun.com/display/GlassFish/3.1.1BuildSchedule, for marking the fixed in with appropriate 3.1.1 build #.

        marina vatkina added a comment -

        Fixed in 3.1.1 b03 with rev 46236

        sherryshen added a comment -

        Verified the fix on v3.2 b03 promoted.
        Thank Marina for the fix.


          People

          • Assignee:
            marina vatkina
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: