glassfish
  1. glassfish
  2. GLASSFISH-16389

RuntimeException occurs when deleting Protocols and unknown character displays in error messages in the locale of zh_TW

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b43
    • Fix Version/s: 3.1.1_b06 , 4.0_b43
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS:Windows 7 32bit and also in Windows 7 x64
      locale:zh_TW
      Browser:Firefox 3.6
      Bundle:java_ee_sdk-6u2-web-b43-windows-ml.exe, also java_ee_sdk-6u3-web-b01-windows-ml.exe

      Description

      step1: create a new network listener named "test". An error occurred which contains unknown character. Pls check the attached picture1.
      step2: create another network listener with the same name "test". An duplicated protocols can't be created,but the error message contains unknown character also. Pls check the attached picture2.
      step3: delete the protocol "test-protocol", and RuntimeException occurs. "test-protocol" can't be deleted. Pls check the attached picture3.

      1. 1.png
        56 kB
      2. 2.jpg
        178 kB
      3. 3.jpg
        67 kB

        Activity

        srinik76 added a comment -

        16388 is a duplicate of 16389 except windows os versions and bundles. updated those versions in the bug and closing 16388 as duplicate.

        srinik76 added a comment -

        Checked in the v3 (3.2) trunk branch.

        Sending src/main/resources/grizzly/networkListenerNew.jsf
        Transmitting file data .
        Committed revision 46887.

        srinik76 added a comment -

        Why fix this issue in 3.1.1?
        o Protocol deletion fails when network listeners created with default protocol name for locale others than en_US
        Which is the targeted build of 3.1.1 for this fix?
        o MS4 (The fix has been checked in the trunk, just need to backport the change to the branch.)
        Do regression tests exist for this issue?
        o No. need manual testing
        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        o verify the bug reported is fixed.

        scatari added a comment -

        Approved for 3.1.1.

        srinik76 added a comment -

        Checked in 3.1.1 branch.

        Sending grizzly/networkListenerNew.jsf
        Transmitting file data .
        Committed revision 46910.


          People

          • Assignee:
            srinik76
            Reporter:
            li.wu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: