glassfish
  1. glassfish
  2. GLASSFISH-16448

Add packager modules for new 4.0 features

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0_b76_EE7MS5
    • Component/s: packaging
    • Labels:
      None

      Description

      Packager modules which will produce IPS packages for new 4.0 features need to be added into workspace and populated with content. Existing metapackages and incorporation packages need to be updated to use new packages as dependencies.

        Activity

        Snjezana Sevo-Zenzerovic created issue -
        Jill Sato made changes -
        Field Original Value New Value
        Affects Version/s 4.0 [ 10970 ]
        Affects Version/s 3.2 [ 10969 ]
        Joe Di Pol made changes -
        Fix Version/s 4.0_b49_ms4 [ 15638 ]
        Fix Version/s 4.0_ms04 [ 14746 ]
        Romain Grécourt made changes -
        Summary Add packager modules for new 3.2 features Add packager modules for new 4.0 features
        Romain Grécourt made changes -
        Assignee Snjezana Sevo-Zenzerovic [ snjezana ] Romain Grécourt [ romain_grecourt ]
        Hide
        Nazrul added a comment -

        Support for JSON Processing has been added already. We will need to add support for Batch, JCache and potentially concurrency JSRs.

        Show
        Nazrul added a comment - Support for JSON Processing has been added already. We will need to add support for Batch, JCache and potentially concurrency JSRs.
        Hide
        Nazrul added a comment -

        Getting help from Snjezana.

        Show
        Nazrul added a comment - Getting help from Snjezana.
        Nazrul made changes -
        Assignee Romain Grécourt [ romain_grecourt ] Snjezana Sevo-Zenzerovic [ snjezana ]
        Snjezana Sevo-Zenzerovic made changes -
        Fix Version/s 4.0_b76_EE7MS5 [ 16105 ]
        Fix Version/s 4.0_b49 [ 15638 ]
        Description Packager modules which will produce IPS packages for new 3.2 features need to be added into workspace and populated with content. Existing metapackages and incorporation packages need to be updated to use new packages as dependencies. Packager modules which will produce IPS packages for new 4.0 features need to be added into workspace and populated with content. Existing metapackages and incorporation packages need to be updated to use new packages as dependencies.
        Snjezana Sevo-Zenzerovic made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Hide
        Snjezana Sevo-Zenzerovic added a comment -

        Closing since the same requirement is being tracked through individual issues such as GLASSFISH-19614 and GLASSFISH-19604.

        Show
        Snjezana Sevo-Zenzerovic added a comment - Closing since the same requirement is being tracked through individual issues such as GLASSFISH-19614 and GLASSFISH-19604 .
        Snjezana Sevo-Zenzerovic made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]

          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Snjezana Sevo-Zenzerovic
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: