glassfish
  1. glassfish
  2. GLASSFISH-16521

ClassNotFoundException: org.jvnet.hk2.annotations.Service causes NoSuchObjectException in SFSB_passivate test on AIX

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.1.1_b05
    • Component/s: failover
    • Labels:
      None
    • Environment:

      AIX 6.1 and JDK 1.6

      Description

      glassfish-3.1.1-b03-aix.zip

      SFSB_passivate test failed on AIX 6.1.
      The same test passed on glassfish-3.1.1-b03.zip and Solaris 10, and RHLinux 5.
      I will provide test details next.

        Activity

        marina vatkina added a comment -

        Mahesh, it's AIX error. 3.1 wasn't tested on AIX.

        Manifest in ha-file-store.jar doesn't list hk2 dependencies outside the class-path (which might be not enough for felix to resolve it correctly, or do it on AIX). Compare manifest entries in ha-file-store.jar and ejb-container.jar

        sherryshen added a comment -

        On another aix machine (aixas11.us.oracle.com) with a later IBM JDK (SR9), the tests passed on b05 without
        error of Caused by: java.lang.ClassNotFoundException: org.jvnet.hk2.annotations.Service.

        ++ hostname
        + echo 'Hostname is: ' aixas11
        OS is: AIX aixas11 1 6 0001BBAAD200

        ++ uname -a
        + echo 'OS is: ' AIX aixas11 1 6 0001BBAAD200
        OS is: AIX aixas11 1 6 0001BBAAD200
        + echo 'JAVA_HOME is ' /usr/java6_64
        JAVA_HOME is /usr/java6_64

        + java -version
        java version "1.6.0"
        Java(TM) SE Runtime Environment (build pap6460sr9fp1-20110208_03(SR9 FP1))
        IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr9-20110203_74623 (JIT enabled, AOT enabled)
        J9VM - 20110203_074623
        JIT - r9_20101028_17488ifx3
        GC - 20101027_AA)
        JCL - 20110203_01

        Mahesh Kannan added a comment -

        I tested this from my workspace (svn version: 47078) and the devtest/sjb/sfsb/passivateactivate passed.

        Mahesh Kannan added a comment -

        Marking it as fixed in b05 as reported by Sherry


          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: