glassfish
  1. glassfish
  2. GLASSFISH-16575

Object doesn't support this property or method at ... resource/common/js/adminjsf.js line 2091

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None

      Description

      Though it seems consistent on some machines, it seems like a timing issue. Line 2091 is

      adminggui.ajax.pingHeader()

      inside the admingui.ajax.get function

      It seems that it's possible for this line of code to be executed prior to the loading of the definition of pingHeader (which is defined at the end of the object's declarations)

        Activity

        brimimc created issue -
        Anissa Lam added a comment -

        Can you be more specific on what you are experiencing ?

        Anissa Lam made changes -
        Field Original Value New Value
        Assignee Anissa Lam [ anilam ] Jason Lee [ jdlee ]
        brimimc added a comment -

        I receive a script error when using the admin gui - the error message is

        Object doesn't support this property or method at ... resource/common/js/adminjsf.js line 2091

        The method it is complaining about seems to be pingHeader()

        It looks like a timing issue, if the page is slow to load, it's possible for this line of code to be executed prior to the complete loading of the adminjsf.js. Since pingHeader is defined at the end of the file it's not yet defined.

        brimimc added a comment -

        Is that enough detail or do you need more info?

        Jason Lee added a comment -

        What browser and OS? Do you have a set of steps we can follow to reproduce this? I'm not seeing it locally. :|

        brimimc added a comment -

        Win7/XP 32 bit IE8 - but we have seen it work on XP 32 bit IE8 as well. I don't think it's a platform issue, but a timing issue (e.g if you machine is slower it's more likely to happen).

        I'll try and get a stack trace for you, but you should be able to help it along by adding a bunch of noop code before the definition of pingHeader to delay the loading of the method definition.

        brimimc added a comment -

        Also of note this is being displayed in the embedded active x IE component - not sure if this have any relation other than it may be slower than the external browser?

        brimimc added a comment -

        This was in the log:

        07:59:38.06][ERROR]: SCRIPT ERROR: Object doesn't support this property or method at http://msass4:4848/resource/common/js/adminjsf.js line 2091
        [07:59:38.17][ERROR]: Error was in: function() {
        admingui.ajax.loadPage(

        { url : url, target: document.getElementById('content'), oldOnClickHandler: oldOnClick, sourceNode: node }

        );
        return false;
        }
        [07:59:38.18][INFO]: Received DOM Event: [BID: 0][FPATH: ][TYPE: click][PATH: //A[@id='treeForm:tree:applications:applications_link']][LOC: 594, 160][THINK: 175][URL: http://msass4:4848/common/index.jsf][TAG: A][SUBTAG: ][VALUE: Applications]

        Anissa Lam made changes -
        Tags 3_1-next
        Anissa Lam made changes -
        Tags 3_1-next 3_1-next 3_1_1-scrubbed
        Jason Lee added a comment -

        I just noticed that you said "this is being displayed in the embedded active x IE component". Does that mean you're NOT using the standalone Internet Explorer application but are, rather, using a third party app that embeds IE via this ActiveX control? If so, what app is that? Is it publicly/freely available? I have not been able to reproduce this issue on my WinXP VM with IE 8.

        Jason Lee added a comment -

        Can this same user reproduce the issue on the more traditional standalone IE 8 on the same box?

        Jason Lee added a comment -

        I'm not sure the no-op code would achieve much, because, as I understand things, Javascript is single threaded. When the browser finds a script tag, it loads (either from the page or the specified remote resource) the Javascript source and processes it before moving on to the next element on the page. I've done some searching for a definitive answer on that and haven't found anything to contradict it. If I'm wrong, and you know of a definitive refutation, I'd certainly love to see it.

        brimimc added a comment -

        No, it does seem limited to the embedded active X component.

        In fact we may have found the problem outside of glassfish. I'll verify this and get back to you.

        Anissa Lam added a comment -

        any update ?
        We will close this issue on Friday, 6/17, if we don't hear anything. thanks.

        brimimc added a comment -

        Yes, go ahead and close it. It was due to xmlhttprequest being hijacked and not a problem in glassfish. Sorry for the bogus case.

        Jason Lee added a comment -

        Closed per reporter's request.

        Jason Lee made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]

          People

          • Assignee:
            Jason Lee
            Reporter:
            brimimc
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: