glassfish
  1. glassfish
  2. GLASSFISH-16610

AIX 6.1. "NoClassDefFoundError: com.sun.org.apache.xerces.internal.parsers.DOMParser", the deployment of jaxrpc-simple.ear failed.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 3.1.2_b02
    • Component/s: web_services
    • Labels:
      None

      Description

      AIX 6.1 glassfish 3.1.1 build 04. Deployed jaxrpc-simple.ear, the deployment failed with such error messages in server.log. I've attached the archive.
      ========================================================================================================

      DEPLOYMENT jaxrpc-simple
      [#|2011-05-10T15:59:32.447-0700|SEVERE|glassfish3.1|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=11;_ThreadName=Thread-8;|Exception while preparing the app|#]

      [#|2011-05-10T15:59:32.448-0700|SEVERE|glassfish3.1|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=11;_ThreadName=Thread-8;|com.sun.org.apache.xerces.internal.parsers.DOMParser
      java.lang.NoClassDefFoundError: com.sun.org.apache.xerces.internal.parsers.DOMParser
      at com.sun.xml.rpc.processor.modeler.j2ee.xml.Factory.loadDocument(Factory.java:275)
      at com.sun.xml.rpc.processor.modeler.j2ee.xml.Factory.loadDocument(Factory.java:267)
      at com.sun.xml.rpc.processor.modeler.j2ee.JaxRpcMappingXml.<init>(JaxRpcMappingXml.java:68)
      at com.sun.xml.rpc.tools.wscompile.J2EEToolPlugin.createModelInfo(J2EEToolPlugin.java:83)
      at com.sun.xml.rpc.util.JaxRpcObjectFactoryImpl.createJ2EEModelInfo(JaxRpcObjectFactoryImpl.java:84)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createFullMappingModelInfo(JaxRpcRICodegen.java:512)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createFullMappingModelInfo(JaxRpcRICodegen.java:497)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createModelInfo(JaxRpcRICodegen.java:452)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.jaxrpcWebService(JaxRpcRICodegen.java:790)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.accept(JaxRpcRICodegen.java:329)
      at com.sun.enterprise.deployment.WebBundleDescriptor.visit(WebBundleDescriptor.java:1999)
      at com.sun.enterprise.deployment.Application.visit(Application.java:1777)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.run(JaxRpcRICodegen.java:156)
      at org.glassfish.webservices.JAXRPCCodeGenFacadeImpl.run(JAXRPCCodeGenFacadeImpl.java:60)
      at org.glassfish.webservices.WebServicesDeployer.prepare(WebServicesDeployer.java:177)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:871)
      at org.glassfish.javaee.full.deployment.EarDeployer.prepareBundle(EarDeployer.java:290)
      at org.glassfish.javaee.full.deployment.EarDeployer.access$200(EarDeployer.java:86)
      at org.glassfish.javaee.full.deployment.EarDeployer$1.doBundle(EarDeployer.java:141)
      at org.glassfish.javaee.full.deployment.EarDeployer$1.doBundle(EarDeployer.java:138)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnBundles(EarDeployer.java:215)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnAllTypedBundles(EarDeployer.java:224)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnAllBundles(EarDeployer.java:253)
      at org.glassfish.javaee.full.deployment.EarDeployer.prepare(EarDeployer.java:138)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:871)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:410)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:380)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1045)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1244)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:455)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:212)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:238)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:822)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1013)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:736)
      Caused by: java.lang.ClassNotFoundException: com.sun.org.apache.xerces.internal.parsers.DOMParser
      at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:77)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:383)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:643)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      at org.apache.felix.framework.ExtensionManager$ExtensionManagerModule.getClassByDelegation(ExtensionManager.java:697)
      at org.apache.felix.framework.resolver.WireImpl.getClass(WireImpl.java:99)
      at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1390)
      at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:722)
      at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
      at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      ... 53 more

      #]

      [#|2011-05-10T15:59:32.489-0700|SEVERE|glassfish3.1|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=11;_ThreadName=Thread-8;|Exception while preparing the app : com.sun.org.apache.xerces.internal.parsers.DOMParser
      java.lang.ClassNotFoundException: com.sun.org.apache.xerces.internal.parsers.DOMParser
      at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:77)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:383)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:643)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      at org.apache.felix.framework.ExtensionManager$ExtensionManagerModule.getClassByDelegation(ExtensionManager.java:697)
      at org.apache.felix.framework.resolver.WireImpl.getClass(WireImpl.java:99)
      at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1390)
      at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:722)
      at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
      at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      at com.sun.xml.rpc.processor.modeler.j2ee.xml.Factory.loadDocument(Factory.java:275)
      at com.sun.xml.rpc.processor.modeler.j2ee.xml.Factory.loadDocument(Factory.java:267)
      at com.sun.xml.rpc.processor.modeler.j2ee.JaxRpcMappingXml.<init>(JaxRpcMappingXml.java:68)
      at com.sun.xml.rpc.tools.wscompile.J2EEToolPlugin.createModelInfo(J2EEToolPlugin.java:83)
      at com.sun.xml.rpc.util.JaxRpcObjectFactoryImpl.createJ2EEModelInfo(JaxRpcObjectFactoryImpl.java:84)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createFullMappingModelInfo(JaxRpcRICodegen.java:512)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createFullMappingModelInfo(JaxRpcRICodegen.java:497)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.createModelInfo(JaxRpcRICodegen.java:452)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.jaxrpcWebService(JaxRpcRICodegen.java:790)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.accept(JaxRpcRICodegen.java:329)
      at com.sun.enterprise.deployment.WebBundleDescriptor.visit(WebBundleDescriptor.java:1999)
      at com.sun.enterprise.deployment.Application.visit(Application.java:1777)
      at org.glassfish.webservices.codegen.JaxRpcRICodegen.run(JaxRpcRICodegen.java:156)
      at org.glassfish.webservices.JAXRPCCodeGenFacadeImpl.run(JAXRPCCodeGenFacadeImpl.java:60)
      at org.glassfish.webservices.WebServicesDeployer.prepare(WebServicesDeployer.java:177)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:871)
      at org.glassfish.javaee.full.deployment.EarDeployer.prepareBundle(EarDeployer.java:290)
      at org.glassfish.javaee.full.deployment.EarDeployer.access$200(EarDeployer.java:86)
      at org.glassfish.javaee.full.deployment.EarDeployer$1.doBundle(EarDeployer.java:141)
      at org.glassfish.javaee.full.deployment.EarDeployer$1.doBundle(EarDeployer.java:138)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnBundles(EarDeployer.java:215)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnAllTypedBundles(EarDeployer.java:224)
      at org.glassfish.javaee.full.deployment.EarDeployer.doOnAllBundles(EarDeployer.java:253)
      at org.glassfish.javaee.full.deployment.EarDeployer.prepare(EarDeployer.java:138)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:871)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:410)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:380)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1045)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1244)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:455)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:212)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:238)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:822)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1013)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:736)

      #]

        Activity

        easarina added a comment -

        jaxrpc-simple.ear

        Hong Zhang added a comment -

        The stack trace is from JAXRPC code gen, assign to webservices team for evaluation

        easarina added a comment -

        I've re-run the test and this problem gone.

        Bhakti Mehta added a comment -

        Cannot reproduce the problem so closing the bug


          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: