Issue Details (XML | Word | Printable)

Key: GLASSFISH-16622
Type: Bug Bug
Status: Resolved Resolved
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Amy Roh
Reporter: ckuehl
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
glassfish

Root applications (context root "/") listen on all virtual servers until server is restarted.

Created: 12/May/11 04:23 PM   Updated: 14/Oct/11 11:54 PM   Resolved: 14/Oct/11 11:53 PM
Component/s: web_container
Affects Version/s: 3.1_b43
Fix Version/s: 4.0_b06

Time Tracking:
Not Specified

File Attachments: 1. XML File domain.xml (29 kB) 17/May/11 07:00 PM - ckuehl
2. Text File server.log (15 kB) 17/May/11 07:00 PM - ckuehl

Environment:

Debian inside VServer


Tags: 3_1-next virtual_server deployment context_root
Participants: Amy Roh, ckuehl and Hong Zhang


 Description  « Hide

When I deploy a web application with the context root of "/" via the web administrative panel to a virtual server listening on domain "example.com", the application will act as if deployed to every virtual server, including the admin panel. Restarting the server (via asadmin) fixes the problem (after a restart, it only listens on example.com). This happens on initial deployment of an application and upon redeployment of an application.

When redeploying an application, I am selecting the file and clicking OK. I am not changing any options from their default options. After redeploying, the admin panel will cease the function and will instead show errors (such as resource not found) and act as if I am accessing that resource.



Hong Zhang added a comment - 13/May/11 11:09 AM

I tried with both admin cli and console (specifying the virtual server as part of the deployment), and the domain.xml application-ref enetry has the specified virtual server as expected.
Assign to web team to check if the application is also only loaded on the specified virtual server as expected and follow up with the user.


ckuehl added a comment - 15/May/11 07:06 PM

Thanks for looking into this. I did some further testing and it appears to only happen when redeploying an existing application via the web panel, not during initial deployment as I initially reported.


Amy Roh added a comment - 17/May/11 06:39 PM

Hi ckuehl,

To clarify, you're saying if you redeploy an existing application with the context root of "/" using the admin gui, the application will act as if it deployed to every virtual server including the admin webapp and the admin gui will cease to function until restart, correct?

Does this also happen when you redeploy using admin cli and not the admin gui?

Can you please include your domain.xml and server.log after you redeploy in order for us to understand your exact setup?

Thanks,
Amy


ckuehl added a comment - 17/May/11 06:59 PM

Hi,

Yes, your summary is correct.

I have just tested and it also happens when redeploying via the CLI:

asadmin> redeploy --name GraalCenterAccounts /home/appman/GraalCenterAccounts.war
Enter admin user name> admin
Enter admin password for user "admin">
Application deployed with name GraalCenterAccounts.
Command redeploy executed successfully.

I will attach my domain.xml and server.log.

Thanks again for looking into this.


ckuehl added a comment - 23/May/11 06:25 AM

I'd like to clarify again:

When redeploying, it does not act as if deployed to all virtual servers. Instead, all applications, including the administrative GUI, act as if undeployed. I see the "Your server is now running" page when trying to access other applications.

This is also happening occasionally when using the asadmin cli.


Amy Roh added a comment - 26/May/11 01:59 PM

I tried your scenario on mac and everything works as expected. I'm trying to understand how and if our configurations are different.

I see "User [] from host localhost does not have administration access" in your server.log. How are you accessing the admin gui? Can you access it locally?


ckuehl added a comment - 28/May/11 08:40 AM

I tried to setup reliable steps to replicate this bug but was unable to on a different system than the one it occurred on. I have updated to 3.2-b06 and the problem has resolved itself.

Thanks again for the help.


Amy Roh added a comment - 31/May/11 09:54 AM - edited

Issue resolved as the reporter stated. Couldn't reproduce.