Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.1_b09, 4.0_b08
    • Component/s: admin_gui
    • Labels:
      None

      Description

      After you shut down DAS, the screen shown (localhost:4848/common/appServer/shutdown.jsf) seems to be missing some background images used for look and feel. When you compare this to the login screen, the missing pieces are obvious. See attached.

      Please update for both open source and commercial distributions.

      1. Login.png
        73 kB
      2. restart.jpg
        122 kB
      3. ShutDownDAS.png
        70 kB

        Activity

        scatari added a comment -

        Not a serious enough issue to be considered for inclusion in 3.1.1.

        Anissa Lam added a comment -

        we should fix both shutdown and restart screen.
        shutdown screen shows no image.
        restart screen has broken image and the S-curve as background which is wrong.

        Since we don't have customized branding page for shutdown or restart (RFE thats never implemented), we can just use the 'generic' image the admin console adapter use when waiting for GUI to load.
        The image can be found in v3/core/kernel/src/main/java/com/sun/enterprise/v3/admin/adapter/backimage.jpg.

        sirajg added a comment -

        Why fix this issue in 3.1.1?
        Improve user experience

        Which is the targeted build of 3.1.1 for this fix?
        next build

        Do regression tests exist for this issue?
        No, manual testing

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        Look at shutdown and restart pages

        scatari added a comment -

        Approved for 3.1.1_b09.

        sirajg added a comment -

        Fixed for open source(community-theme) branding

        Anissa Lam added a comment -

        Fixed the priority order of the shutdown screen in the custom branding jar.
        Also ported the change from 3.1.1 to trunk.
        All the fix is in both trunk and 3.1.1 branch, for both shutdown and restart screen and for both community and oracle brand.

        mark as resolved.


          People

          • Assignee:
            sirajg
            Reporter:
            Nazrul
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: