glassfish
  1. glassfish
  2. GLASSFISH-16823

No validation for installation directory when editing a node

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.2_b06
    • Component/s: admin
    • Labels:
      None
    • Environment:

      3.1 b43

      Description

      When user creates a CONFIG node and enters an invalid installation directory the following error message is displayed:

      An error has occurred
      Installdir value $

      {com.sun.aas.productRoot}/glassfish/nodes is not a valid glassfish installation.

      However, when a CONFIG node is created, e.g. without an installation directory specified, and an invalid directory is entered on Edit Node screen, the change is saved without a warning. As a result, when user later tries to create an instance under such node, the following error is displayed:

      Command succeeded with Warning
      Failed to execute local command: C:\as\v31\glassfish3\glassfish\nodes\glassfish\bin\asadmin.bat is not executable.

      The instance appears to be created but cannot be started, since it was only created in domain.xml.

      It seems that we should be validating installation directory when editing an existing node as well, and not just during the node creation. This issue is present for both SSH and CONFIG nodes - no validation is done on installation directory on Edit Node screen.

      Steps to reproduce:

      1. Create a config node, specifying node name and localhost for node host.
      2. Go to the Edit screen for the newly created node and enter ${com.sun.aas.productRoot}

      /glassfish/nodes for installation directory. Save changes.
      3. Go to Create Standalone Instance screen and create a new instance on the node. Warning is displayed.

        Activity

        Anissa Lam added a comment -

        Validation comes from the backend.
        Transfer to Joe for evaluation.

        Joe Di Pol added a comment -

        I've reproduced this with a CONFIG node when editing. When you create a new node, if the node's host is the local host then the create code will validate the installdir – but edit does not do this. (If the host is not the local host then we can't validate the installdir in either case).

        For an SSH node I do not see this problem. Editing an SSH node and changing installdir to an invalid path generates a validation error as expected.

        I'm lowering the priority since this is not a major loss of functionality. Assigning to Carla since she did the installdir check in create-node-config.

        carlavmott added a comment -

        This bug was fixed in 3.1.2 workspace and also the trunk.


          People

          • Assignee:
            carlavmott
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: