glassfish
  1. glassfish
  2. GLASSFISH-16875

Deploying webservice with HandlerChain annotation fails with too many errors.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: v3.0.1
    • Fix Version/s: 4.0_b74
    • Component/s: deployment, web_services
    • Labels:
      None
    • Environment:

      All glassfish v 3.0.1 metro

      Description

      When I deploy a webservice implemented as a metro provider Api webservice with a @HandlerChain(file="somefile.xml") annotation, the deployment will cause the following SEVERE annotation error.

      [#|2011-06-16T12:41:21.139-0400|SEVERE|glassfish3.0.1|global|_ThreadID=30;_ThreadName=Thread-1;|component referenced from annotation symbol cannot be found
      symbol: javax.jws.HandlerChain
      location: class test.handlers.HTest|#]

      However, the webservice and handler are deployed and is working.
      The issue is when I redeploy my webservices (I have several endpoints in my war) it says there are too many errors and deployment fails.

      [#|2011-06-16T12:20:38.889-0400|SEVERE|glassfish3.0.1|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=29;_ThreadName=Thread-1;|Exception while deploying the app
      java.lang.IllegalStateException: Too many errors, annotation processing abandoned.
      at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:458)
      at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:420)
      at com.sun.enterprise.deployment.archivist.Archivist.readRestDeploymentDescriptors(Archivist.java:396)
      at com.sun.enterprise.deployment.archivist.Archivist.readDeploymentDescriptors(Archivist.java:373)
      at com.sun.enterprise.deployment.archivist.Archivist.open(Archivist.java:238)
      at com.sun.enterprise.deployment.archivist.Archivist.open(Archivist.java:247)
      at com.sun.enterprise.deployment.archivist.Archivist.open(Archivist.java:208)
      at com.sun.enterprise.deployment.archivist.ApplicationFactory.openArchive(ApplicationFactory.java:148)
      at org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:162)
      at org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:79)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.loadDeployer(ApplicationLifecycle.java:612)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.setupContainerInfos(ApplicationLifecycle.java:554)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:262)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:183)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:272)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:305)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:320)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1176)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:83)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1235)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1224)
      at org.glassfish.admingui.common.util.LocalDeploymentFacility$LocalDFCommandRunner.run(LocalDeploymentFacility.java:138)
      at org.glassfish.deployment.client.AbstractDeploymentFacility.deploy(AbstractDeploymentFacility.java:350)
      at org.glassfish.admingui.common.util.DeployUtil.invokeDeploymentFacility(DeployUtil.java:89)
      at org.glassfish.admingui.common.util.DeployUtil.deploy(DeployUtil.java:66)
      at org.glassfish.admingui.common.handlers.DeploymentHandler.deploy(DeploymentHandler.java:186)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handler.java:442)
      at com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:420)
      at com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:394)
      at com.sun.jsftemplating.layout.event.CommandActionListener.invokeCommandHandlers(CommandActionListener.java:150)
      at com.sun.jsftemplating.layout.event.CommandActionListener.processAction(CommandActionListener.java:98)
      at javax.faces.event.ActionEvent.processListener(ActionEvent.java:88)
      at javax.faces.component.UIComponentBase.broadcast(UIComponentBase.java:772)
      at javax.faces.component.UICommand.broadcast(UICommand.java:300)
      at com.sun.webui.jsf.component.WebuiCommand.broadcast(WebuiCommand.java:166)
      at javax.faces.component.UIViewRoot.broadcastEvents(UIViewRoot.java:775)
      at javax.faces.component.UIViewRoot.processApplication(UIViewRoot.java:1267)
      at com.sun.faces.lifecycle.InvokeApplicationPhase.execute(InvokeApplicationPhase.java:82)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:312)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1523)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:343)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:223)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:256)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:641)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:97)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:85)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:185)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:325)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:226)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:239)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:170)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: Too many errors, annotation processing abandoned.
      at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:350)
      at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:368)
      at org.glassfish.apf.impl.AnnotationProcessorImpl.processAnnotations(AnnotationProcessorImpl.java:282)
      at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:188)
      at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:129)
      at com.sun.enterprise.deployment.archivist.Archivist.processAnnotations(Archivist.java:581)
      at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:447)
      ... 73 more

      #]

        Issue Links

          Activity

          Lukas Jungmann added a comment -

          yes, please. If you have a testcase, just go ahead and attach it. Thanks!

          jinahya added a comment -

          I'm using 3.1.2.2. I still have the same situation. As mentioned, the handler actually seems work regardless of the warning message but, in my case, a NPE occurs by a null ThreadLocal variable. I have to restart the GF process everytime I RE-deploy the war.

          Lukas Jungmann added a comment -

          see related GLASSFISH-19659

          Lukas Jungmann added a comment -

          can reproduce in GF 3.1.2.2 but not in trunk, marking as cannot reproduce

          abhi0123 added a comment - - edited

          I'm seeing this on glassfish-4.0-b89 and came across this thread. It is obviously not fixed yet. As others have noted, the handler chain actually gets invoked but that doesn't make the message any less annoying. Will attach working code if someone wants to take a look.

          [2013-11-03T15:44:44.452-0500] [glassfish 4.0] [SEVERE] [] [global] [tid: _ThreadID=36 _ThreadName=admin-listener(5)] [timeMillis: 1383511484452] [levelValue: 1000] [[
            Component referenced from annotation symbol cannot be found
           symbol: javax.jws.HandlerChain
           location: class name.abhijitsarkar.learning.webservices.jaxws.security.ut.CalculatorUT]]
          

            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              Mhui
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: