Issue Details (XML | Word | Printable)

Key: GLASSFISH-16896
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: naman_mehta
Reporter: Jagadish
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

3.1.1 version is not logged in server.log

Created: 22/Jun/11 09:55 PM   Updated: 30/Jun/11 05:34 AM   Resolved: 30/Jun/11 05:34 AM
Component/s: logging
Affects Version/s: 3.1.1
Fix Version/s: 3.1.1_b10

Time Tracking:
Not Specified

Tags: 3_1_1-approved
Participants: Jagadish and naman_mehta


 Description  « Hide

I see that the server.log of 3.1.1 still logging "glassfish3.1" as product id in log-record.
[Though it is logged as 3.1.1-SNAPSHOT in server startup message of server.log]

[#|2011-06-23T02:28:23.792+0530|INFO|glassfish3.1|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=34;_ThreadName=Thread-2;|MQJMSRA_RA1101: GlassFish MQ JMS Resource Adapter stopping...|#]

It seems to be due to the fact that we do not consider "update_version" flag while constructing the "product-id"
Refer : com.sun.enterprise.server.logging.UniformLogFormatter.getProductId()

whenever the update_version is "0", we can ignore it and if it is non-zero we can use it.



naman_mehta added a comment - 28/Jun/11 02:13 AM

Why fix this issue in 3.1.1?
Printing wrong product version in all the logs.

Which is the targeted build of 3.1.1 for this fix?
build#10

Do regression tests exist for this issue?
No need

Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
No need. It can be monitored easily in server.log file or log viewer screen.

File Diff for the same:
Index: core/logging/src/main/java/com/sun/enterprise/server/logging/UniformLogFormatter.java
===================================================================
— core/logging/src/main/java/com/sun/enterprise/server/logging/UniformLogFormatter.java (revision 47737)
+++ core/logging/src/main/java/com/sun/enterprise/server/logging/UniformLogFormatter.java (working copy)
@@ -183,7 +183,8 @@
if (branding == null) { return null; }

  • String version = branding.getAbbreviatedVersion() + branding.getVersionPrefix() + branding.getMajorVersion() + "." + branding.getMinorVersion();
    + String version = branding.getAbbreviatedVersion() + branding.getVersionPrefix() + branding.getMajorVersion()
    + + "." + branding.getMinorVersion() + "." + branding.getUpdateVersion();
    return (version);
    }

naman_mehta added a comment - 30/Jun/11 05:34 AM

Sending logging/src/main/java/com/sun/enterprise/server/logging/UniformLogFormatter.java
Transmitting file data .
Committed revision 47770.