Issue Details (XML | Word | Printable)

Key: GLASSFISH-16911
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Harshad Vilekar
Reporter: Bhavanishankar
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

ORB throws NPE if the GlassFish is stopped without undeploying the Remote EJB

Created: 24/Jun/11 11:11 PM   Updated: 02/Dec/11 07:25 PM   Resolved: 30/Jun/11 10:04 PM
Component/s: orb
Affects Version/s: 3.1.1, 4.0
Fix Version/s: 3.1.1_b10

Time Tracking:
Not Specified

File Attachments: 1. Text File exception.txt (18 kB) 27/Jun/11 10:54 AM - Bhavanishankar
2. Java Source File Test.java (3 kB) 24/Jun/11 11:12 PM - Bhavanishankar


Tags: 3_1_1-approved
Participants: Bhavanishankar and Harshad Vilekar


 Description  « Hide

In the recent 3.1.1 build, GlassFish seems to be throwing NPE when it is shutdown without undeploying the remote EJB.

(This is a side effect of GLASSFISH-16546 fix).

It is simple to reproduce:

0. Install latest 3.1.1 nightly build of GlassFish.
1. Start GlassFish
2. Deploy the remoteejb.jar (attachment is in GLASSFISH-16546)
3. Stop GlassFish
4. Check the server.log for exception.

Alternatively, you can also download the attached Test.java and keep it under /tmp. Also download remoteejb.jar (attachment from GLASSFISH-16546) and keep it under /tmp/. Set S1AS_HOME to 3.1.1 installation.

Compile & run the test like this:

javac -cp $S1AS_HOME/lib/embedded/glassfish-embedded-static-shell.jar Test.java
java -cp $S1AS_HOME/lib/embedded/glassfish-embedded-static-shell.jar:. Test



Bhavanishankar added a comment - 24/Jun/11 11:12 PM

test program attached.


Harshad Vilekar added a comment - 27/Jun/11 12:48 PM

Need to catch the NPE during ORB destroy processing.

The fix is ready, and is currently under pre-integration testing.


Harshad Vilekar added a comment - 30/Jun/11 10:04 PM - edited

Fixed in GlassFish 3.1.1-B10 + Corba 3.1.0-B29.