glassfish
  1. glassfish
  2. GLASSFISH-16946

Installer fails to install the pkg bits on a random basis

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: installation
    • Labels:
      None

      Description

      GLASSFISH-9208 seems to be more than a usability issue.
      Users are reporting that install sometimes never completes once it has reached the dreaded 41% stage.

        Activity

        Alexis MP added a comment -

        if the root cause is an unreachable pkg server then the installer should really be trying to ping the pkg server before installing the pkg bits

        scatari added a comment -

        Perhaps this will be resolved through an integration of updated update center. Not sure if B10 included it or not.

        Snjezana Sevo-Zenzerovic added a comment -

        b10 already contains final build of UC 2.3u4, so things will not magically get better on that account

        It seems that we are having another bout of repository issues. As far as I can tell from all related forum postings, the issue is not necessarily that server URL is not reachable - in that case, bootstrap does exit rather promptly. The problem is that connection to the server gets intermittently lost once the bootstrap is already in progress. So, even pinging the repository before starting the download would not help.

        The only apparent solution is to get server side back in order.

        Snjezana Sevo-Zenzerovic added a comment -

        Reported issue was eventually resolved by adjusting timeout settings - see GLASSFISH-16999. Closing as duplicate since at this point there are no other reported problems with UC repositories.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Alexis MP
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: