glassfish
  1. glassfish
  2. GLASSFISH-16958

Administration Console is gone after a while

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.1_b11
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Win7 Pro SP1 64 Bit de_DE

      Description

      Sporadically it happens that administration console is just "gone":

      It happened two times in the past day that on http://localhost:4848 the following text is shown:

      oracle.com
      GlassFish Server 3.1

      Your server is now running
      To replace this page, overwrite the file index.html in the document root folder of this server. The document root folder for this server is the docroot subdirectory of this server's domain directory.

      To manage a server on the local host with the default administration port, go to the Administration Console.

      (etc.)

      The funny thing is that the the word "Administration Console" actually is a link to http://localhost:4848, so clicking on it shows exactly the same page again.

      The server.log does not tell anything about this strange circumstances: Only the usual message are contained that the console was started.

        Activity

        mkarg added a comment -

        About the prio: I need to object since the prio should not be dependend on your local success to reproduce it but solely upong the actualy impact on the user, which is independend of your personal situation. We have two machines here that produce the behaviour and are about to ship GF 3.1.1 to 200+ enterprises world wide and expect that many of those will call our hotline to complain about this problem, which induces costs that should (and could) be prevented.

        About the scenarios: No more need to send you the EAR. At one machine where it happens with our EAR we updated from 3.1 to 3.1.1_b11 and THAT scenario is gone then. So it makes no sense to further insist on getting any SuperSimple.ear that produces this problem as THAT scenario only happened back in 3.1. But, the second scenario (the one that you also cannot reproduce) happens on 3.1.1_b11 and to make you believe I will attach a video so you see what we do exactly to crash it. That machine is a HP Z400 QuadXeon with Win7 Pro SP1 64 Bit de_DE running a Firefox 3.6.18. Maybe you should use such an environment as it possible does not happen on a Mac?

        mkarg added a comment -

        "How To Crash Admin GUI" video, showing that a freshly installed GF can be crashed easily by just clicking in the GUI while the domain is restarting.

        Anissa Lam added a comment -

        >> About the scenarios: No more need to send you the EAR. At one machine where it happens with our EAR we updated from 3.1 to 3.1.1_b11 and THAT scenario is gone then. So it makes no sense to further insist on getting any SuperSimple.ear that produces this problem as THAT scenario only happened back in 3.1.
        Just want to confirm this. Are you saying that you no longer experience the problem where "deploy/undeploy several times using CLI results in not getting the admin console" is no longer reproducible using 3.1.1 b11 ?
        If that is the case, do u mind that I mark this "Cannot reproduce" or "Fixed" since thats what this issue is about ?

        Thanks for the video, not that i don't believe you, i just can't reproduce it on my Mac.
        I will open another issue for this 2nd scenario – "Cannot access admin console when server is restarting" , will that be fine with you ?
        I think it makes it clearer that way.

        mkarg added a comment -

        While I do not see a need to close this and open another issue, I do not object that and hereby confirm that in GFv3.1.1_b11 the deploy/undeploy case is not reproducible. The only open issue now is the one shown in the video.

        Anissa Lam added a comment -

        Closing this as "Cannot Reproduce" in 3.1.1_b11.
        I have opened GLASSFISH-17086 for the "Admin Console is not available during server re-start". mkarg, you may want to add yourself to watch that issue. That bug is set to "Critical" at your request
        If you can attach server.log to GLASSFISH-17086, that will help too.
        thanks.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            mkarg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: