glassfish
  1. glassfish
  2. GLASSFISH-16962

Adding an instance to cluster causes false indication to restart other cluster instances

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.1_b11
    • Fix Version/s: 3.1.1_b11, 4.0
    • Component/s: admin
    • Labels:
      None
    • Environment:

      ogs-3.1.1-b11-07_04_2011-aix.zip, Firefox 5 on Windows XP

      Description

      When a new instance is added to an existing cluster, status for all previously running instances is changed from "running" to "restart required". Adding an instance to a cluster should not require cluster restart. This is specifically problematic, since user cannot look up the reason for restart required messages for instances other than DAS in Admin Console.

      Steps to reproduce:

      In Admin Console:
      1. Create a cluster with one instance, e.g. cl1 with cl1in1, on localhost-domain1 node.
      2. Start cluster.
      3. Go to cluster cl1, Instances page and click on New.
      4. Fill in the instance name, e.g. cl1in2, and click OK. Note that after creation page with instances is displayed and the existing instance, cl1in1, has status "restart required".

      The same status is reported by CLI:

      /export/sqe/lidia/glassfish3/glassfish/nodes/localhost-domain1/cl1in1/logs % asadmin list-instances
      in1 running
      cl1in1 running; requires restart
      cl1in2 not running

      No errors or warnings are present in DAS server.log and the following warning is present in the first clustered instance server.log (cl1in1):

      [#|2011-07-05T18:23:41.775-0700|WARNING|oracle-glassfish3.1.1|null|_ThreadID=13;
      _ThreadName=Thread-9;|Unprocessed event : UnprocessedChangeEvent

      {PropertyName=sy stem-property, OldValue = null, NewValue = GlassFishConfigBean.com.sun.enterpris e.config.serverbeans.SystemProperty, Source = GlassFishConfigBean.com.sun.enterp rise.config.serverbeans.Server}

      , reason = The system-property, OSGI_SHELL_TELNET
      _PORT, that is referenced by the Java configuration, was modified, when = 130991
      5421592|#]

      1. server.log.cl1in1
        16 kB
        lidiam
      2. server.log.das
        18 kB
        lidiam

        Activity

        Tom Mueller added a comment -

        Confirmed the reported behavior.

        The root cause of this problem is that the GenericJavaConfigListener assumes that it is receiving SystemProperty change events only for its own system properties. However, it also receives change events for other instances that are added to the configuration. To fix this, it needs to ignore those events.

        lidiam added a comment -

        Changed Summary to better reflect the problem. Also, this is a regression compared with Glassfish 3.1 b43.

        Tom Mueller added a comment - - edited

        The reason why this bug doesn't show up in 3.1 but does show up in 3.1.1 is because there was a mistake in the implement of the fix for issue GLASSFISH-15987 which was implemented during the 3.1.1 release cycle.

        Why fix this issue in 3.1.1?
        This is a regression of functionality from a previous release (3.1).

        Which is the targeted build of 3.1.1 for this fix?
        Build 11

        Do regression tests exist for this issue?
        No

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        Tests related to changing system-properties that are referenced by JVM options.

        Tom Mueller added a comment -

        Fixed in revision 47933 on the trunk
        and in revision 47934 on the 3.1.1 branch.

        lidiam added a comment -

        Verified in promoted build ogs-3.1.1-b11-aix.zip.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: