Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1, 3.1.1_b09, 3.1.2
    • Fix Version/s: 3.1.2_b13, 4.0
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      weld-osgi-bundle 1.1.1.Final

      Description

      Because of a slight API change in SLF4J I am unable to use version 1.6.x because the "weld-osgi-bundle" doesn't play well with it:

      WARNING: Failed to deploy bundle com.something.support.web [319]
      org.glassfish.osgijavaeebase.DeploymentException: Deployment of com.something.support.web [319] failed because of following reason: Failed while deploying bundle com.something.support.web [319] : \
          java.lang.RuntimeException: Failed to deploy bundle [ com.something.support.web [319] ], \
          root cause: Exception while loading the app
      	at org.glassfish.osgijavaeebase.AbstractOSGiDeployer.deploy(AbstractOSGiDeployer.java:125)
      	at org.glassfish.osgijavaeebase.OSGiContainer.deploy(OSGiContainer.java:154)
      	at org.glassfish.osgijavaeebase.JavaEEExtender.deploy(JavaEEExtender.java:107)
      	at org.glassfish.osgijavaeebase.JavaEEExtender.access$200(JavaEEExtender.java:61)
      	at org.glassfish.osgijavaeebase.JavaEEExtender$HybridBundleTrackerCustomizer$1.call(JavaEEExtender.java:151)
      	at org.glassfish.osgijavaeebase.JavaEEExtender$HybridBundleTrackerCustomizer$1.call(JavaEEExtender.java:148)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.RuntimeException: Failed to deploy bundle [ com.something.support.web [319] ] \
          , root cause: Exception while loading the app
      	at org.glassfish.osgijavaeebase.OSGiDeploymentRequest.deploy(OSGiDeploymentRequest.java:196)
      	at org.glassfish.osgijavaeebase.OSGiDeploymentRequest.execute(OSGiDeploymentRequest.java:118)
      	at org.glassfish.osgijavaeebase.AbstractOSGiDeployer.deploy(AbstractOSGiDeployer.java:121)
      	... 10 more
      Caused by: java.lang.NoSuchMethodError: org.slf4j.spi.LocationAwareLogger.log(Lorg/slf4j/Marker; \
          Ljava/lang/String;ILjava/lang/String;Ljava/lang/Throwable;)V
      	at org.slf4j.cal10n.LocLogger.info(LocLogger.java:122)
      	at org.jboss.weld.bootstrap.WeldBootstrap.<clinit>(WeldBootstrap.java:213)
      	at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:345)
      	at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:99)
      	at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:186)
      	at org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:257)
      	at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:461)
      	at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
      	at org.glassfish.osgijavaeebase.OSGiDeploymentRequest.deploy(OSGiDeploymentRequest.java:183)
      	... 12 more
      

      So obviously weld is not compatible with SLF4J 1.6.x and hence should not be wired to such a version.

      I already filed an upstream issue:

      https://issues.jboss.org/browse/WELD-932

        Issue Links

          Activity

          Cheng Fang added a comment -

          Any updates? ejb devtests (ejb31/embedded/embedasync) are still failing with GlassFish 3.1.2 due to this issue.

          Bhavanishankar added a comment -

          This issue is very important for Embedded GlassFish

          ancoron added a comment -

          Upgrade to weld 1.1.3.SP1 and everything should be fine.

          kshitiz_saxena added a comment -

          With latest weld integration 1.1.4.Final, this issue is no longer reproducible.

          Cheng verified that testcase is working on latest build.

          Marking this issue as resolved.

          ancoron added a comment -

          Thank you very much!


            People

            • Assignee:
              Sivakumar Thyagarajan
              Reporter:
              ancoron
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: