glassfish
  1. glassfish
  2. GLASSFISH-17047

Embedded fails to start on missing template file

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: embedded
    • Labels:
      None
    • Environment:

      Trunk revision 47966

      Description

      using glassfish-embedded-web.jar from trunk revision 47966, starting GlassFish Embedded fails with this error :

      Jul 13, 2011 1:10:06 AM com.sun.enterprise.v3.services.impl.LogManagerService postConstruct
      WARNING: /var/folders/CV/CVhj8DvqEwGK5bdJKK9TaE+++TI/Tmp/gfembed287464934846218930tmp/config/logging.properties not found, creating new file from template.
      Exception in thread "main" java.lang.IllegalArgumentException: File source doesn't exist
      at com.sun.enterprise.util.io.FileUtils.copy(FileUtils.java:795)
      at com.sun.enterprise.v3.services.impl.LogManagerService.postConstruct(LogManagerService.java:139)
      at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:130)
      at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:117)
      at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:83)
      at com.sun.hk2.component.SingletonInhabitant.get(SingletonInhabitant.java:66)
      at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:139)
      at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:130)
      at com.sun.enterprise.v3.server.AppServerStartup.run(AppServerStartup.java:229)
      at com.sun.enterprise.v3.server.AppServerStartup.doStart(AppServerStartup.java:145)
      at com.sun.enterprise.v3.server.AppServerStartup.start(AppServerStartup.java:136)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.start(GlassFishImpl.java:79)
      at com.mycompany.glassfish31embeddedhelloworld.App.<init>(App.java:38)
      at com.mycompany.glassfish31embeddedhelloworld.App.main(App.java:171)

        Activity

        Bhavanishankar added a comment -

        This can not be the case unless there is something specific in your environment. Because all the embedded tests are running fine in both 3.1.1 and 3.2.

        I have verified manually with all 3 builds viz., 3.1.1-b11, 3.1.1-SNAPSHOT and 3.2-SNAPSHOT (latest) and it works fine.

        My test program is like this:

        
        import java.io.*;
        import org.glassfish.embeddable.*;
        
        public class Test {
        
          public static void main(String... args) throws Exception {
        
            GlassFishRuntime runtime = GlassFishRuntime.bootstrap();
        
            GlassFish glassfish = runtime.newGlassFish();
        
            glassfish.start();
        
            glassfish.dispose();
        
          }
        
        }
        
        

        The output in all cases is like this:

        
        bhavani@sholay: ~/tmp/embedded/issue_17047$ java -cp /tmp/glassfish-embedded-web-3.1.1-SNAPSHOT.jar:. Test
        Jul 19, 2011 12:12:47 PM com.sun.enterprise.v3.services.impl.GrizzlyService createNetworkProxy
        INFO: Network listener http-listener on port 0 disabled per domain.xml
        Jul 19, 2011 12:12:47 PM com.sun.enterprise.v3.services.impl.GrizzlyService createNetworkProxy
        INFO: Network listener https-listener on port 0 disabled per domain.xml
        Jul 19, 2011 12:12:47 PM com.sun.enterprise.v3.server.AppServerStartup run
        INFO: GlassFish Server Open Source Edition 3.1.1-SNAPSHOT (java_re-private) startup time : Embedded (515ms), startup services(232ms), total(747ms)
        Jul 19, 2011 12:12:47 PM org.glassfish.admin.mbeanserver.JMXStartupService$JMXConnectorsStarterThread run
        INFO: JMXStartupService: JMXConnector system is disabled, skipping.
        Jul 19, 2011 12:12:47 PM org.glassfish.admin.mbeanserver.JMXStartupService shutdown
        INFO: JMXStartupService and JMXConnectors have been shut down.
        Jul 19, 2011 12:12:47 PM com.sun.enterprise.v3.server.AppServerStartup stop
        INFO: Shutdown procedure finished
        Jul 19, 2011 12:12:47 PM AppServerStartup run
        INFO: [Thread[GlassFish Kernel Main Thread,5,main]] exiting
        
        
        Bhavanishankar added a comment -

        Please re-open by attaching the test case if the problem persists in your environment.


          People

          • Assignee:
            Bhavanishankar
            Reporter:
            Alexis MP
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: