glassfish
  1. glassfish
  2. GLASSFISH-17083

Invalid http_proxy value can cause DAS to fail to start and then fail to exit

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.1_b11
    • Fix Version/s: 3.1.2, 4.0
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Ubuntu 11.04, Java(TM) SE Runtime Environment (build 1.6.0_23-b05), GlassFish Server Open Source Edition 3.1.1-b11 (build 11).

      Description

      Some times when I try to start domain,the start-domain command fails and in the subsequent invocation it works.This is the output I see:

      sreekanth@spidy:/space/Sreekanth/servers/glassfish3/glassfish$ asadmin start-domain domain1
      Waiting for domain1 to start .......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
      No response from the Domain Administration Server (domain1) after 600 seconds.
      The command is either taking too long to complete or the server has failed.
      Please see the server log files for command status.
      Please start with the --verbose option in order to see early messages.
      Command start-domain failed.

      I did a jps and have 2 processes running:
      sreekanth@spidy:/space/Sreekanth/workspace/RSP-BSP/metro-ws-i-tests~rsp-bsp$ jps
      2990 admin-cli.jar
      3068 ASMain
      3468 Jps

      I took out jstack for each one and I am attaching the output of jstack here to the bug report.

      Then when I again say : asadmin start-domain , I see this:

      sreekanth@spidy:/space/Sreekanth/servers/glassfish3/glassfish$ asadmin start-domain domain1
      Waiting for domain1 to start ............................
      Successfully started the domain : domain1
      domain Location: /space/Sreekanth/servers/glassfish3/glassfish/domains/domain1
      Log File: /space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/logs/server.log
      Admin Port: 4848
      Command start-domain executed successfully.

      1. server.log
        551 kB
        Sreekanth
      2. t.out
        4 kB
        Sreekanth
      3. t1.out
        5 kB
        Sreekanth

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Tom Mueller
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: