glassfish
  1. glassfish
  2. GLASSFISH-17086

Cannot access Admin Console during server re-start

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      HP Z400 QuadXeon with Win7 Pro SP1 64 Bit de_DE Firefox 3.6.18

      Description

      This issue is seen and reported by mkarg when he was experiencing problem as described in GLASSFISH-16958.
      GLASSFISH-16958 itself is no longer reproducible in 3.1.1 b11 and is closed.

      Here is the steps to reproduce this issue:

      asadmin start-domain
      open browser to view localhost:4848
      click somewhere, e. g. server-config
      asadmin restart-domain
      click somewhere else WHILE THE RESTART IS IN PROGRESS STILL
      browser will wait until the restart is done and then show a nice glassfish-provided page telling that this JSF is not found

      Here is the environment:
      That machine is a HP Z400 QuadXeon with Win7 Pro SP1 64 Bit de_DE running a Firefox 3.6.18.

      mkarg even took the time to capture the video on how to reproduce this. The video is attached in GLASSFISH-16958, and can be downloaded from http://java.net/jira/secure/attachment/46737/HowToCrashAdminGUI.wmv

      requested mkarg to attach server.log when this problem occurs.

        Activity

        mkarg added a comment -

        server.log recorded with default logging levels while doing the same as shown in the video.

        It seems the logging level is not fine enough to see something particularly interesting. In this case, you should tell me which logger must be set to what level to make you see the really interesting things.

        Dies Koper added a comment -

        I think I just ran into this issue too. I'll add my environment's details in case it helps:

        My steps:
        1. Downloaded GFv3.1.1-b12 and installed on WinXP (English, but with OS region set to Japanese)
        2. asadmin start-domain
        3. Accessed Admin Console with IE 8 (Preferred Language set to 1. en_AU, 2. en_US)
        4. Visited server-config->HTTP Service and enabled Access Logging and ' (%time-taken%ms)' to Format.
        5. Visited server (Admin Server) and clicked on Restart, OK.
        6. Waited 10 or so seconds.
        7. Clicked on 'here' in Console message "Click here to return to the login page after the server has been started. This may take a few seconds."

        While I was redoing these steps to confirm I didn't miss anything it happened again, so it seems to be reproducible.

        The GF process is still running although it's confused about it:

        D:\tests\GFv3.1.1\glassfish-3.1.1-b12\glassfish3>jps
        34744 Jps
        36592 ASMain
        D:\tests\GFv3.1.1\glassfish-3.1.1-b12\glassfish3>bin\asadmin start-domain
        There is a process already using the admin port 4848 – it probably is another instance of a GlassFish server.
        Command start-domain failed.
        D:\tests\GFv3.1.1\glassfish-3.1.1-b12\glassfish3>bin\asadmin list-commands
        Remote server does not listen for requests on [localhost:4848]. Is the server up?
        Command list-commands failed.

        I'll attach my server.log, jstack output and access log.

        Jason Lee added a comment -

        I'm having trouble reproducing this, but I also just fixed an unrelated bug that may be affecting the behavior here. Can you try the nightly build from tonight or next week's promoted build (b11) and see if this problem still persists? I'll keep trying on my end to see if I can reproduce this. Thanks.

        Jason Lee added a comment -

        I am still unable to reproduce this using either Anissa's or Markus' instructions. Unless I hear that others can reproduce, I think I'll close this.

        Jason Lee added a comment -

        I can not reproduce this and haven't gotten any recent updates on others' ability to reproduce, so I'm going to close this. If it reoccurs, feel free to reopen.


          People

          • Assignee:
            Jason Lee
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: