Issue Details (XML | Word | Printable)

Key: GLASSFISH-17092
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Harshad Vilekar
Reporter: Harshad Vilekar
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
glassfish

CORBA Warning message on glassfish shutdown

Created: 22/Jul/11 11:15 PM   Updated: 24/Dec/11 01:25 AM   Resolved: 23/Dec/11 04:43 PM
Component/s: orb
Affects Version/s: 3.1.2, 4.0
Fix Version/s: 3.1.2_b16, 4.0

Time Tracking:
Not Specified

Issue Links:
Dependency
 

Tags: 3_1-next 3_1_1-scrubbed 3_1_2-approved
Participants: Harshad Vilekar and scatari


 Description  « Hide

Server log shows the message "WARNING: IOP02310830: ReferenceFactoryManager destroy failed" when glassfish is shutdown.

Steps:
1. asadmin start-domain
2. deploy EJB app with remote interface
3. asadmin stop-domain
4. Check out server.log.

Note: The message is not printed if the app is undeployed before stopping the domain.

--------------- server.log --------------------------------
:
:
[#|2011-07-22T14:22:17.254-0700|INFO|glassfish3.1.1|javax.enterprise.system.tools.admin.com.sun.enterprise.v3.admin|_ThreadID=19;_Thre adName=Thread-39;|Server shutdown initiated|#]

[#|2011-07-22T14:22:17.282-0700|WARNING|glassfish3.1.1|javax.enterprise.resource.corba.POA|_ThreadID=19;_ThreadName=Thread-39;|IOP02310830: ReferenceFactoryManager destroy failed
org.omg.CORBA.OBJ_ADAPTER: WARNING: IOP02310830: ReferenceFactoryManager destroy failed vmcid: OMG minor code: 830 completed: No
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:248)
at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:95)
at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.handleFullLogging(WrapperGenerator.java:387)
at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.access$400(WrapperGenerator.java:107)
at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator$2.invoke(WrapperGenerator.java:511)
at com.sun.corba.ee.spi.orbutil.proxy.CompositeInvocationHandlerImpl.invoke(CompositeInvocationHandlerImpl.java:99)
at $Proxy138.rfmDestroyFailed(Unknown Source)
at com.sun.corba.ee.impl.oa.rfm.ReferenceFactoryManagerImpl.destroy(ReferenceFactoryManagerImpl.java:575)
at com.sun.corba.ee.impl.oa.rfm.ReferenceFactoryImpl.destroy(ReferenceFactoryImpl.java:66)
at org.glassfish.enterprise.iiop.impl.POARemoteReferenceFactory.destroy(POARemoteReferenceFactory.java:555)
at com.sun.ejb.containers.BaseContainer.doContainerCleanup(BaseContainer.java:4333)
at com.sun.ejb.containers.BaseContainer.onShutdown(BaseContainer.java:4237)
at org.glassfish.ejb.startup.EjbApplication.stop(EjbApplication.java:307)
at org.glassfish.internal.data.EngineRef.stop(EngineRef.java:169)
at org.glassfish.internal.data.ModuleInfo.stop(ModuleInfo.java:302)
at org.glassfish.internal.data.ApplicationInfo.stop(ApplicationInfo.java:322)
at com.sun.enterprise.v3.server.ApplicationLifecycle.unload(ApplicationLifecycle.java:999)
at com.sun.enterprise.v3.server.ApplicationLifecycle.disable(ApplicationLifecycle.java:1971)
at com.sun.enterprise.v3.server.ApplicationLoaderService.stopApplication(ApplicationLoaderService.java:454)
at com.sun.enterprise.v3.server.ApplicationLoaderService.preDestroy(ApplicationLoaderService.java:422)
at com.sun.hk2.component.AbstractCreatorInhabitantImpl.dispose(AbstractCreatorInhabitantImpl.java:83)
at com.sun.hk2.component.SingletonInhabitant.release(SingletonInhabitant.java:81)
at com.sun.hk2.component.EventPublishingInhabitant.release(EventPublishingInhabitant.java:108)
at com.sun.hk2.component.LazyInhabitant.release(LazyInhabitant.java:133)
at com.sun.enterprise.v3.server.AppServerStartup.stop(AppServerStartup.java:425)
at com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.stop(GlassFishImpl.java:88)
at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.stop(GlassFishDecorator.java:68)
at com.sun.enterprise.v3.admin.StopServer.doExecute(StopServer.java:70)
at com.sun.enterprise.v3.admin.StopDomainCommand.execute(StopDomainCommand.java:95)
at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355)
at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.run(CommandRunnerImpl.java:383)
Caused by: java.lang.NullPointerException
at com.sun.corba.ee.impl.oa.poa.POAImpl.getPOAFactory(POAImpl.java:334)
at com.sun.corba.ee.impl.oa.poa.POAImpl.<init>(POAImpl.java:467)
at com.sun.corba.ee.impl.oa.poa.POAImpl.find_POA(POAImpl.java:1028)
at com.sun.corba.ee.impl.oa.rfm.ReferenceFactoryManagerImpl.destroy(ReferenceFactoryManagerImpl.java:557)
... 23 more

#]
-----------------------------------------------

This Warn message need not (should not ?) show up in the server log by default. To resolve - the log level need to be changed to FINE (or FINEST).



scatari made changes - 26/Jul/11 07:15 AM
Field Original Value New Value
Tags 3_1-next 3_1_1-scrubbed
scatari added a comment - 26/Jul/11 07:16 AM

No impact on shutdown, these are just warning messages that need to be cleaned up.


Harshad Vilekar made changes - 14/Dec/11 11:40 PM
Tags 3_1-next 3_1_1-scrubbed 3_1-next 3_1_1-scrubbed 3_1_2-review
Harshad Vilekar made changes - 20/Dec/11 12:06 AM
Link This issue blocks GLASSFISH-17852 [ GLASSFISH-17852 ]
Harshad Vilekar added a comment - 23/Dec/11 07:04 AM
  • What is the impact on the customer of the bug?
    Exception message logged in server log during shutdown.
  • How likely is it that a customer will see the bug and how serious is the bug?
    Shows up every time the server running remote EJB is shutdown.
  • Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
    Exists in 3.1.1 also.
  • What is the cost/risk of fixing the bug?
    Fix is ready.
  • How risky is the fix? How much work is the fix? Is the fix complicated?
    Low risk. Only affects shutdown operation.
  • Is there an impact on documentation or message strings?
    No.
  • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
    Tests that exercise Remote EJBs. Embedded GlassFish tests.
  • Which is the targeted build of 3.1.2 for this fix?
    B16.

Joe Di Pol made changes - 23/Dec/11 03:09 PM
Fix Version/s 3.1.2_b16 [ 15330 ]
Tags 3_1-next 3_1_1-scrubbed 3_1_2-review 3_1-next 3_1_1-scrubbed 3_1_2-approved
Harshad Vilekar made changes - 23/Dec/11 04:43 PM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Fixed [ 1 ]
Harshad Vilekar added a comment - 24/Dec/11 01:22 AM

Trunk - Committed revision 51754.


Harshad Vilekar made changes - 24/Dec/11 01:22 AM
Affects Version/s 4.0 [ 10970 ]
Affects Version/s 3.1.1_b12 [ 14853 ]
Harshad Vilekar made changes - 24/Dec/11 01:25 AM
Fix Version/s 4.0 [ 10970 ]
Affects Version/s 3.1.2 [ 15100 ]