glassfish
  1. glassfish
  2. GLASSFISH-17101

JMS Connection Factory lookup failed with clustered JMS

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Linux 64 bit, Glassfish 3.1 in cluster

      Description

      JMS Connection Factory lookup failed
      Environment:
      Clustered Glassfish 3.1 with JMS cluster(built-in OpenMQ)
      JMS cluster setup:
      JMS Availability : shareddb
      Mode(EMBEDDED/LOCAL/REMOTE): LOCAL

      Source code to get ConnectionFactory:
      javax.naming.InitialContext jndi = new javax.naming.InitialContext();
      ConnectionFactory qFactory = (ConnectionFactory) jndi.lookup("jms/queueConnectionFactory");

      It seems jms/queueConnectionFactory is not available in the context.

        Activity

        Satish Kumar added a comment -

        This is a duplicate of 17099. Hence closing this issue.

        kumara added a comment -

        Please provide detailed steps to reproduce including how JMS cluster was configured and where/how the code segment is being run.


          People

          • Assignee:
            Satish Kumar
            Reporter:
            magnus12345678
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: