Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b08
    • Fix Version/s: 4.0_b74
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      GF V3.2

      Description

      Accessed :http://localhost:8080/javatype_serializable/AccessSerializableBeanServlet?testCase=testString_NoLob
      testString_Lob
      testSerializable_NoLob
      testSerializable_Lob
      reported the same exception "transaction aborted" as the server_jpa.log.
      thanks!

        Activity

        marina vatkina added a comment -

        Exception comes from JPA (after that the transaction will be rolled back):

        Exception [EclipseLink-6168] (Eclipse Persistence Services - 2.2.0.v20110202-r8913): org.eclipse.persistence.exceptions.QueryException
        Exception Description: Query failed to prepare, unexpected error occurred: [java.lang.IndexOutOfBoundsException: Index: 0, Size: 0].
        Internal Exception: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        Query: DoesExistQuery(referenceClass=StringBuffer )
        at org.eclipse.persistence.exceptions.QueryException.prepareFailed(QueryException.java:1542)

        Mitesh Meswani added a comment -

        The root cause for this issue is in EclipseLink code. Eclipselink has been hardened in this area recently; I am marking this issue as fixed. Please reopen if that is not the case.


          People

          • Assignee:
            Mitesh Meswani
            Reporter:
            caojun_12482
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: