glassfish
  1. glassfish
  2. GLASSFISH-17208

If Connection Validation failured, physical connection could be leaked.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.1
    • Fix Version/s: None
    • Component/s: jdbc
    • Labels:
      None
    • Environment:

      windows32

      Description

      CPManagedConnectionFactory、DMManagedConnectionFactory、DSManagedConnectionFactory、XAManagedConnectionFactory have a method of createManagedConnection . The function of createManagedConnection is to create ManagedConnection and return ManagedConnection. If Connection Validation failured, physical connection could be leaked.( In the gui the location of Connection Validation is Resources->JDBC Connection Pools->DerbyPool->Advanced-> Connection Validation)

      Directory: jdbc\jdbc-ra\jdbc-core\src\main\java
      Package: com.sun.gjc.spi
      Class:DSManagedConnectionFactory
      Method: createManagedConnection
      Line
      132	   gedConnection mc = constructManagedConnection(null, dsConn, pc, this);
      133
      134        //GJCINT
      135        validateAndSetIsolation(mc);
      136        return mc;
      

      If the line of 132 or 135 throws resourceException, the physical connection could not be closed. So that the physical connection may be leaked.

        Activity

        Shalini added a comment -

        Duplicate of issue 17159.


          People

          • Assignee:
            Shalini
            Reporter:
            lzg5039
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: