glassfish
  1. glassfish
  2. GLASSFISH-17269

Custom Installation crashed when "Configure an existing installation"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 3.1.1_b12
    • Fix Version/s: future release
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Bundle: ogs-3.1.1-b12-unix-ml.sh and glassfish-3.1.1-b12-unix-ml.sh
      OS: OEL5 x64
      locale: en_US

      Description

      1. Install the bundle;
      2. Choose "Custom Installation" in Installation Type page and then Next;
      3. Choose "Install Only" in Installation page and then Next;
      4. Click Back in Install Directory page;
      5. Choose "Configure an existing installation" in Installation page and Next;
      6. Click Next in Install Directory page and then GUI window disappears. Installation crashes.

        Activity

        scatari added a comment -

        This is not reproducible with 3.1.1 FCS build, closing.

        li.wu added a comment -

        This issue occurs in glassfish3.1.2_b05.
        Bundle: glassfish-3.1.2-b05-windows-ml.exe
        OS: windows7

        Please check the pictures attached.
        On step2.jpg choose Custom Installation and click Next;
        On step3.jpg choose Install Only and click Next;
        On step4.jpg click BACK;
        On step5.jpg choose Configure an existing installation and click Next;
        On step6.jpg click Next. And then Installation GUI exits.

        scatari added a comment -

        Romain,
        Please take a look at this. Send me an email if you need access to a windows m/c.

        Thanks

        Romain Grécourt added a comment -

        I've been able to reproduce the bug with Windows XP SP3.
        I could not reproduce the bug on step6 as the installer complained that no GlassFish installation was found under C:\glassfish3.

        However, if you go in the "configure an existing installation" panel, and then go back to the "custom installation" panel and try to hit the button "next" of the "install only" panel, the installer will crash.

        Romain Grécourt added a comment -

        I also reproduced the issue on Linux and Solaris, so this issue is not platform dependent.

        Romain Grécourt added a comment -

        Fixed with revision #51948. Fixed installers can be downloaded from hudson job (http://gf-hudson.us.oracle.com/hudson/job/gf-3.1.2-build-nightly/156/artifact/bundles/) or you can wait for promoted build #17 and download installers from http://dlc.sun.com.edgesuite.net/glassfish/3.1.2/promoted/.

        li.wu added a comment -

        This issue reproduces in 3.1.2_b20 for bundle ogs-3.1.2-b20-windows-ml.exe.
        I downloaded the bundle from http://javaweb.us.oracle.com/java/re/glassfish/3.1.2/promoted/b20/archive/bundles/

        Joe Di Pol added a comment - - edited

        I was able to reproduce this using B21 on Solaris 11. The key seems to be going into "Install Only" and then Backing out before choosing "Configure an existing installation". Since this is likely not a common path, this is probably not a 3.1.2 stopper, but we may want to put something in the release notes. I'm tagging for release notes.

        The work around is to go directly into "Configure an existing installation" and not into one of the other options first.

        Rebecca Parks added a comment -

        Added to 3.1.2 Release Notes:

        Description

        GlassFish Server installation crashes if you perform these steps:

        1. Select Custom Installation on the Installation Type page and then Next.
        2. Select Install Only on the Installation page and then Next.
        3. Select Back on the Install Directory page.
        4. Select Configure an Existing Installation on the Installation page and Next.
        5. Select Next on the Install Directory page.

        Workaround

        To configure an existing installation, go directly to this option without selecting a different option first.


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            li.wu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: