glassfish
  1. glassfish
  2. GLASSFISH-17289

Application scoped resources are not shown when App is deployed with Preserve Application Scoped Resources checkbox checked.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b01
    • Fix Version/s: 3.1.2_b06, 4.0
    • Component/s: jca
    • Labels:
      None
    • Environment:

      OS: Solaris Sparc
      Browser : firefox 3.6.17
      GF 3.1.2 b02

      Description

      Using GF 3.1.2 promoted b02, while deploying an application with scoped resources bundled in glassfish-resources.xml if check the checkbox "Preserve Application Scoped Resources" in the Deployment page of the Console, the application gets deployed, but the Resources tab displaying the application scoped resources does not show up, and hence one is not able to see the application scoped resources for this App.

        Activity

        shaline created issue -
        Nazrul made changes -
        Field Original Value New Value
        Assignee Anissa Lam [ anilam ] sumasri [ sumasri ]
        sumasri added a comment -

        While deploying an app, "Preserve Application Scoped Resources" check box is not required. Hence, removing it from the GUI page.
        Committed the changes from GUI to both trunk(Committed revision 50222) and branch 3.1.2(Committed revision 50223).

        Anyways, this issue is from the back end..Typically, it should not effect the way it is described in the issue even though we pass the property "Preserve Application Scoped Resources". Hence, transferring it to back end team to look into this.

        sumasri made changes -
        Assignee sumasri [ sumasri ] Jagadish [ jr158900 ]
        sumasri made changes -
        Comment [ This is a duplicate of an issue # 17290. ]
        Anissa Lam made changes -
        Component/s jca [ 10602 ]
        Component/s admin_gui [ 10588 ]
        Jagadish added a comment -

        Provided a fix such that the preserveAppScopedResources flag is considered only for "redeploy" or "deploy --force" mode of deployment.

        svn log -v -r 50412
        branches/3.1.2/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/module/ResourcesDeployer.java

        svn log -v -r 50413
        trunk/main/appserver/connectors/connectors-runtime/src/main/java/com/sun/enterprise/connectors/module/ResourcesDeployer.java

        Jagadish made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 3.1.2_b06 [ 15106 ]
        Fix Version/s 4.0 [ 10970 ]
        Resolution Fixed [ 1 ]
        shaline added a comment -

        Verified in GF 3.1.2 b18.

        shaline made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Tags 3_1_2-verified

          People

          • Assignee:
            Jagadish
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: