glassfish
  1. glassfish
  2. GLASSFISH-17369

intermittent failure to edit schedule in Conference Planner demo

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: sample_apps
    • Labels:
      None
    • Environment:

      glassfish on mac 10.5.8
      mozilla firefox 6.0.2 on windows xp

      Description

      I observed the intermittent failure to edit schedule in
      Conference Planner demo on several dev continuous builds
      e.g. #9594 on Sept. 26, #9617 on Sept. 27.

        Activity

        sherryshen added a comment - - edited

        Conference Planner Demo in Native Mode

        1) follow the instruction to setup demo app
        http://aseng-wiki.us.oracle.com/asengwiki/display/GlassFish/Conference+Planner
        I either deploy from admin console or from
        admin cli, e.g.
        asadmin start-domain
        asadmin enable paas-console
        asadmin create-ims-config-native
        asadmin create-template --indexes ServiceType=LB,VirtualizationType=Native LBNative
        asadmin deploy --availabilityenabled=true ConferencePlanner.war
        svn co http://mercurial.us.oracle.com/svn/glassfish/branches/javaone-2011/LoadDatabase/
        cd LoadDatabase
        mvn scala:compile scala:run -Ddb=native

        2) register a user and login from demo app
        http://asqe-xserver-1.us.oracle.com:50080/ConferencePlanner/

        3) click "My Schedule" --"Edit Schedule"
        Some times, I saw the schedule correctly,
        and other time I saw error no matter I deploy
        from console or cli.

        http://asqe-xserver-1.us.oracle.com:50080/ConferencePlanner/myschedule.xhtml
        javax.servlet.ServletException:
        Exception Description: An attempt was made to traverse a relationship using indirection that had a null Session.
        This often occurs when an entity with an uninstantiated LAZY relationship is serialized and that lazy relationship is traversed after serialization. To avoid this issue, instantiate the LAZY relationship prior to serialization.
        root cause
        Exception [EclipseLink-7242] (Eclipse Persistence Services - 2.3.0.v20110604-r9504): org.eclipse.persistence.exceptions.ValidationException
        Exception Description: An attempt was made to traverse a relationship using indirection that had a null Session. This often occurs when an entity with an uninstantiated LAZY relationship is serialized and that lazy relationship is traversed after serialization. To avoid this issue, instantiate the LAZY relationship prior to serialization.

        sherryshen added a comment - - edited

        Saw the same error on today's build
        http://gf-hudson.us.oracle.com/hudson/job/gf-trunk-build-continuous/
        #9632 Sep 28, 2011 12:01:25 PM

        0) Set up as above with admincli deploy and login with a new user.
        1) My Schedue --Edit Schedule
        See ex as before
        2) Tracks – Show Track
        OK with correct track.
        3) My Schedule --Edit Schedule
        OK with correct schedule

        2) seems to be a workaround for demo to continue.

        arungupta added a comment -

        This sample is no longer actively developed but the reported issue was likely fixed in a later version.


          People

          • Assignee:
            arungupta
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: