Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.1.2_dev
    • Component/s: web_container
    • Labels:
      None

      Description

      This deployement descriptor hangs server. After removing, glassfish works fine

      • <cache enabled="true" timeout-in-seconds="300">
      • <cache-mapping>
      • <url-pattern>*.gif</url-pattern>
      • </cache-mapping>
      • <cache-mapping>
      • <url-pattern>/favicon.ico</url-pattern>
      • </cache-mapping>
      • <cache-mapping>
      • <url-pattern>/robots.txt</url-pattern>
      • </cache-mapping>
      • <cache-mapping>
      • <url-pattern>*.gif</url-pattern>
      • </cache-mapping>
      • <cache-mapping>
      • <url-pattern>*.html</url-pattern>
      • </cache-mapping>
      • </cache>

      attaching thread stack dump from locked system.

      1. jstack.txt
        55 kB
        rkolar02
      2. livedump
        109 kB
        rkolar02

        Activity

        rkolar02 added a comment -

        It is the same withoyt ajp_proxy. Yes. I can reporoduce it at any time.

        rkolar02 added a comment -

        stack dump from hanged machine without AJP

        Shing Wai Chan added a comment -

        Can you attach a war file to reproduce the issue?

        Shing Wai Chan added a comment -

        I see the issue now. The issue is triggered by duplicate entry for *.gif and then accessing a gif file.
        As a workaround, one can remove the extra *.gif entry in deployment descriptor.

        Need more investigation on the fix.

        Shing Wai Chan added a comment -

        fix in 3.1.2:
        Sending web-glue/src/main/java/com/sun/appserv/web/cache/filter/CachingFilter.java
        Transmitting file data .
        Committed revision 50320.

        fix in trunk:
        Sending web-glue/src/main/java/com/sun/appserv/web/cache/filter/CachingFilter.java
        Transmitting file data .
        Committed revision 50321.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            rkolar02
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: