glassfish
  1. glassfish
  2. GLASSFISH-1739

REGRESSION: Unable to deploy to "/" on virtual server "server"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      1,739

      Description

      Deploying a webmodule to "/" has stopped working as of the nightly that was
      generated between 12/08 and 12/09.

      This command:

      asadmin deploy --contextroot "/" test.war

      issued against a newly created domain, now fails with this error:

      CLI171 Command deploy failed : Trying to create reference for application in
      target server failed; The context root [] in application [test] is already in
      use by another application on this instance [server]

      This error message can't be true, because "server" does not have any webapps
      deployed to its "/", nor does it declare any default-web-module.

      Several of the web unit tests have started failing because of this.

        Issue Links

          Activity

          jluehe added a comment -

          We just discussed this issue at Bugswat. We agreed that Hong is going to exclude
          "__asadmin" from the check for unique context roots (per virtual server) during
          deployment if no --virtualservers option was specified.

          Hong Zhang added a comment -

          Modify unique context root checking so an occupied context root at __asadmin
          virtual server would not cause any conflict if a user application wants to use
          the same context root.

          Hong Zhang added a comment -
              • Issue 1790 has been marked as a duplicate of this issue. ***
          jfarcand added a comment -
              • Issue 1788 has been marked as a duplicate of this issue. ***
          jluehe added a comment -
              • Issue 1787 has been marked as a duplicate of this issue. ***

            People

            • Assignee:
              Hong Zhang
              Reporter:
              jluehe
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: