glassfish
  1. glassfish
  2. GLASSFISH-17390

StandardWrapper getRootCause: infinite loop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.1.1, 3.1.1
    • Fix Version/s: 3.1.2_b12
    • Component/s: web_container
    • Labels:
      None

      Description

      Basically the same issue as raised and fixed previously in Tomcat 5.x:

      https://issues.apache.org/bugzilla/show_bug.cgi?id=39088

      The problem is that calling a "getRootCause" method via reflection is not safe, because an application-level exception may implement this method with different semantics than ServletException/JspException.

        Activity

        wrschneider99 added a comment -

        BTW: this is likely to prevent me from using Glassfish in production, because a third-party commercial application won't run properly on it. (if it were my own code, it would be an easy workaround.)

        Shing Wai Chan added a comment -

        fix in 3.1.2:
        Sending web-core/src/main/java/org/apache/catalina/core/StandardWrapper.java
        Transmitting file data .
        Committed revision 51162.

        fix in trunk:
        Sending web-core/src/main/java/org/apache/catalina/core/StandardWrapper.java
        Transmitting file data .
        Committed revision 51163.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            wrschneider99
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: