glassfish
  1. glassfish
  2. GLASSFISH-17418

Error Deploying: Exception while invoking class org.glassfish.webservices.WebServicesApplication start method java.lang.NullPointerException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Linux 2.6.26-2-amd64 #1 SMP x86_64 GNU/Linux
      GlassFish Server Open Source Edition 3.2-SNAPSHOT (build 1)

      Description

      I`m developing using Netbeans 7.0.1 a EAR application.

      At localhost it works perfectly:

      • GlassFish Server Open Source Edition 3.1.1 (build 12)
      • 2.6.32-34-generic #77-Ubuntu SMP i686 GNU/Linux.

      But in a production enviromment (see more in this ticket) I get a error deploying using command line or at gui asadmin.

      The stacktrace is above, please, any help will be appreciated.

      Exception while invoking class org.glassfish.webservices.WebServicesApplication start method java.lang.NullPointerException at com.sun.enterprise.v3.services.impl.GrizzlyService.registerEndpoint(GrizzlyService.java:598) at com.sun.enterprise.v3.services.impl.GrizzlyService.registerEndpoint(GrizzlyService.java:576) at com.sun.enterprise.v3.services.impl.GrizzlyService.registerEndpoint(GrizzlyService.java:558) at com.sun.enterprise.v3.services.impl.GrizzlyService.registerEndpoint(GrizzlyService.java:535) at org.glassfish.webservices.WebServicesApplication.start(WebServicesApplication.java:133) at org.glassfish.internal.data.EngineRef.start(EngineRef.java:130) at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:269) at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:294) at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:462) at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240) at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:380) at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355) at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370) at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1064) at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96) at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1244) at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1232) at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:455) at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:212) at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168) at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117) at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:238) at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:822) at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719) at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1013) at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225) at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137) at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104) at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90) at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79) at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54) at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59) at com.sun.grizzly.ContextTask.run(ContextTask.java:71) at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532) at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513) at java.lang.Thread.run(Thread.java:636)

        Activity

        Hong Zhang added a comment -

        assign to webservices team for initial evaluation

        Bhakti Mehta added a comment -

        Please can you attach your application/NB project so we can debug more

        mariohmol added a comment - - edited

        This same project running using ANT as a EAR project in Netbeans, was working, i have just retested but it's NOT works!

        If i take this same code and put into a Maven EAR project, this erros occurs.

        Its very easy to reproduce, create a new MAVEN EAR project and a WebService EJB.

        I'm attaching a zip file with the project if you cant reproduce.

        When a deploy i'm using a virtual server, but i have tested without but the error persists.

        Regards,

        mariohmol added a comment - - edited

        Hy,

        I confused myself, this problem occurs in ANT or MAVEN project.

        I was using 3.2 because it has a bug in 3.1.1 (http://java.net/jira/browse/GLASSFISH-16223) but now it is already fixed.

        So now I'm using latest GF 3.1.1 to production site and everything is working, so its really a bug on 3.2.

        When this bug get fixed please annouce here because I will get 3.2 again to test it.

        Regards,

        Lukas Jungmann added a comment -

        Hi,

        I tried to reproduce the problem in 3.1.2 branch as well as in trunk and I cannot reproduce it (I tried using asadmin command, GF admin console and autodeploy facility). It seems that this issue has been already fixed somehow.

        Feel free to reopen this issue, if you can reproduce this with some latest GF build, ie nightly from: http://dlc.sun.com.edgesuite.net/glassfish/4.0/nightly/ and also attach server log to this issue, please. Thanks!


          People

          • Assignee:
            Lukas Jungmann
            Reporter:
            mariohmol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: