glassfish
  1. glassfish
  2. GLASSFISH-17432

Eclipselink deserialize a empty entity object on remote ejb call.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      SO: Apple Macintosh OS X Lion 10.7.2 (but on Solaris 11 Express, i have a same issue)
      JVM/DK: 1.6.0_26 (build 1.6.0_26-b03-383-11A511)
      Persistence provider: EclipseLink bundled with Glassfish. My app not have any jar as dependency.

      Description

      I have a EJB deployed in Glassfish and a web tier (war) on same application server instance. My web tier call a business method with a entity bean as argument. In EJB logic, the entity is empty. All fields is null.

      My problem is solved using Hibernate. But is very strange the default library (EclipseLink) not work with EJB environment.

      If EclipseLink is not recommended for distributed applications, why this lib is default?

      Thanks.

        Activity

        Mitesh Meswani added a comment -

        You might be hitting the same issue as http://java.net/jira/browse/GLASSFISH-16164. I am assuming that your EJB tier and Web tier is deployed as separate app

        Are you using field based or attribute based persistence?
        Do you have persistence unit defined in both EJB tier and Web tier or only one of them?
        Please try adding <property name="eclipselink.weaving.fetchgroups" value="false"/> to persitsence.xml as a workaround

        shreedhar_ganapathy added a comment -

        Transferring to Mitesh for eval and resolution.

        Mitesh Meswani added a comment -

        Closing as duplicate of http://java.net/jira/browse/GLASSFISH-16164. Please reopen if that is not the case


          People

          • Assignee:
            Mitesh Meswani
            Reporter:
            norasodan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: