glassfish
  1. glassfish
  2. GLASSFISH-17450

Application client can not restore connection after the computer has gone to hibernate / sleep

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: standalone_client
    • Labels:
      None
    • Environment:

      All

      Description

      Just run an app client that uses remote ejbs. Put the computer to hibernate / sleep and try to continue running the app client.

      I also tried jndi lookup of the remote interfaces and it doesn't work either it either freezes or throws a JNDI exception.

        Activity

        Harshad Vilekar added a comment -

        Assign to appclient for initial evaluation.

        Tim Quinn added a comment -

        Sorry, but you did not identify which GlassFish release or which operating system you are using nor did you provide a stack trace from the JNDI error or a thread dump from the hang that would help us understand what might be happening.

        I cannot reproduce the problem on my Mac OS X system with either 3.1.1 or a very recent trunk build.

        I have a very simple EAR containing an EJB and an app client. I deployed the EAR, started the app client, made sure it accessed the EJB a couple times, then put my system to sleep.

        After waking the system, the client continued to contact the EJB successfully. Admittedly, this could be platform-dependent.

        Assuming you can reproduce the problem at will, please

        • let us know which GlassFish release you are using,
        • tell us what operating system you are using,
        • post the JNDI look-up stack trace, and
        • if you see a hang, post a thread dump from both the app client JVM and also the server (just to be sure we capture everything that might be available at the time of the hang).

          People

          • Assignee:
            Tim Quinn
            Reporter:
            pablopina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: