glassfish
  1. glassfish
  2. GLASSFISH-17452

paas console monitoring graph not shown on KVM Ubuntu 64bit firefox 6

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0
    • Component/s: paas-console
    • Labels:
      None
    • Environment:

      Ubuntu 10.10 x86_64 and Firefox 6

      Description

      paas console monitoring graph not shown on KVM Ubuntu 64bit firefox 6

      v4.0 build 7 nightly in glassfish.zip

      During kvm tests, paas console monitoring graph not shown on Ubuntu 64bit firefox 6.
      The monitoring page show the messages repeatedly,
      "This component needs an SVG enable browser like ..., Fireofx 1.5+, ...".
      The test browser is Firefox 6, i.e.
      http://www.ubuntubuzz.com/2011/10/ubuntu-1110-review-and-features.html
      Firefox 6 for Linux/Ubuntu 64bit (tar.bz2)

      1. kvm_firefox6_ubuntu_b08_plus_fix.jpg
        238 kB
      2. kvm_monitoring_b08.jpg
        400 kB
      3. ubuntu_firefox6.jpg
        238 kB
      4. windows7_firefox6_native_b08.jpg
        212 kB
      5. windows7_firefox6_ovm_b08.jpg
        91 kB

        Activity

        sumasri added a comment -

        There is one duplicate line in chart.svg file..
        In the test machine also, charts are showing up after making the change.
        Sent a mail with all the information.
        Will check in the change once it is reviewed from GUI team.

        sherryshen added a comment - - edited

        The monitoring graph is shown on firefox 6 with kvm and ubuntu 10.10.
        http://java.net/jira/secure/attachment/47961/kvm_firefox6_ubuntu_b08_plus_fix.jpg
        This is build 08 with Suma's local fix. Thanks Suma.

        mzh777 added a comment -

        I was able to view the Monitoring page from FireFox 7.0.1 and IE 9 after deleting the extra line in glassfisha3/glassfish/lib/install/applications/__paas-console/images/chart.svg.

        But found a lot error messages in server.log:
        [#|2011-11-04T23:47:47.261+0000|WARNING|44.0|org.apache.myfaces.trinidadinternal.skin.SkinFactoryImpl|_ThreadID=26;_ThreadName=Thread-2;|Cannot find an unversioned skin for family console. We will use the versioned skin console.desktop.|#]

        It repeats itself every 5 second and causing extra logging volume. If this is caused by chart.svg, please let me know and I'll file another bug.

        Anissa Lam added a comment -

        We are aware of this WARNING. It has nothing to do with this issue. It has been there since day 1.
        However, to fix this, we will have to release another version of trinidad and we haven't done that.

        sumasri added a comment -

        Checked in the fix into trunk.

        Sending webapp/src/main/webapp/images/chart.svg
        Transmitting file data .
        Committed revision 50703.


          People

          • Assignee:
            sumasri
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: