glassfish
  1. glassfish
  2. GLASSFISH-17533

When building v3, executing "create-domain" task failed

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: v3.0.1
    • Fix Version/s: None
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      ■OS
      Windows XP SP3 JP
      ■JDK Version
      1.6.0_20-b02
      ■ Maven Version
      Maven 2.2.1
      ■ Glassfish V3 Version
      v3.0 b74b

      Description

      When I build glassfish v3.0(b74.2) from https://svn.java.net/svn/glassfish~svn/tags/3.0-b74b,
      I met a curious problem as following:

      1) Making a building workspace
      The building workspace's directory name is: F:\GlassfishV3\v3(b74b)

      2) cd the building workspace, and execute the following command:
      mvn -Dmaven.repo.local=F:\GlassfishV3\mavenrepo\glassfishv3 install

      3) When executing "create-domain" task, the building process failed,
      -------------------------------------------------------------------------------
      ...
      create-domain:
      [echo] Directory to run command from: F:\GlassfishV3\v3(b74b)\distributions\nucleus/target/stage/glassfishv3/glassfish/bin
      [echo] Command to run: F:\GlassfishV3\v3(b74b)\distributions\nucleus/target/stage/glassfishv3/glassfish/bin/asadmin.bat
      [exec] 'F:\GlassfishV3\v3\' は、内部コマンドまたは外部コマンド、
      [exec] 操作可能なプログラムまたはバッチ ファイルとして認識されていません。
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      ...
      --------------------------------------------------------------------------------

      About the whole building process,please see the log file(build_failure(create-domain).txt).

      In addition, after I changed the building workspace's directory name into "F:\GlassfishV3\v3\b74b" ,
      and executed the build again, the build process is successful(please see the log file(build_success(create-domain).txt)).

      So, I think that building workspace's directory name with '()' can cause the problem.

      --Best Regard
      --Tang Yong

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            janey
            Reporter:
            TangYong
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:

              Time Tracking

              Estimated:
              Original Estimate - 2 days
              2d
              Remaining:
              Remaining Estimate - 2 days
              2d
              Logged:
              Time Spent - Not Specified
              Not Specified